Subaru Impreza GC8 & RS Forum & Community banner
1 - 11 of 11 Posts

·
Registered
Joined
·
18 Posts
Discussion Starter · #1 ·
Bought 98 RS car runs smooth it just started making a horrible screeching sound all of a sudden idk
what it could be
 

·
Registered
Joined
·
54 Posts
It appears you posted a live event vs. recording and uploading a youtube video so there is no way for us to actually see the engine running and hear the noise.
 

·
Administrator
2000 RSTi
Joined
·
1,791 Posts
I can see the YouTube video fine. It sounds like a 1960s Hollywood war movie. Not sure what it could be but I hope you got that car for cheap.
 
  • Like
Reactions: lordizzy

·
Registered
Joined
·
54 Posts
I can see the video now as well. Around the 10 second mark it seems it stops momentarily abs from what it seems the engine sounds okay. Did you try revving to see if any change? Also notice ac belt not on so it can’t be that. I did have a car before where the power steering fluid was leaking and when the pump was empty it would make a screeching noise.
 

·
Registered
Joined
·
18 Posts
Discussion Starter · #5 ·
I can see the video now as well. Around the 10 second mark it seems it stops momentarily abs from what it seems the engine sounds okay. Did you try revving to see if any change? Also notice ac belt not on so it can’t be that. I did have a car before where the power steering fluid was leaking and when the pump was empty it would make a screeching noise.
Yea it stops momentarily then it will stop for a while then it randomly comes back when i revv it it goes away only happens at idle.
 

·
Registered
Joined
·
18 Posts
Discussion Starter · #6 ·
I can see the video now as well. Around the 10 second mark it seems it stops momentarily abs from what it seems the engine sounds okay. Did you try revving to see if any change? Also notice ac belt not on so it can’t be that. I did have a car before where the power steering fluid was leaking and when the pump was empty it would make a screeching noise.
also the car does run fine no loss of power or anything.
 

·
Registered
98RS, 98RS, 99RS
Joined
·
425 Posts
It seems like maybe something could be stuck in side the timing cover and getting wedged against the belt or something. Or if a loose bearing was making noise at idle it would go away under load; my porsche transmission does that and it sounds similar when the car is in gear.
 

·
Registered
Joined
·
40 Posts
it sounds like a power steering pump or a timing belt idler.
Can you take the accessory belt off and start it for a minute? when was the belt last replaced? sometimes when people over tighten the belt it wears the bearings out really fast..
 

·
Registered
Joined
·
1,314 Posts
if it's not the power steering pump, or the alternator, it's likely a timing component, unless you know they were replaced.
 

·
Registered
Joined
·
18 Posts
Discussion Starter · #10 ·
if it's not the power steering pump, or the alternator, it's likely a timing component, unless you know they were replaced.
i think it might be the alternator car now is taking a little long to start an battery is brand new
 

·
Registered
Joined
·
1,314 Posts
take that belt off and fire it up! answer that question real quick. you can then also spin the pulleys by hand, they should move very freely.
 
1 - 11 of 11 Posts
Top