Subaru Impreza GC8 & RS Forum & Community banner
1 - 8 of 8 Posts

·
Registered
95 GC 371hp/355tq ej25 1.5xtr
Joined
·
4,494 Posts
Discussion Starter · #1 ·
i got the RS registered today and got emissions done (passed), while driving i noticed from a stop when i go into first it grinds a little. lets say im at a stop, and in N with the clutch out, i clutch in and go into first (thats when it grinds a little).

any one have this problem? could it be clutch fluid or it needs a good bleed. i did it but only 2 times with DOT 3 brake fluid.
 

·
Registered
1998 impreza 2.5rs
Joined
·
630 Posts
Mine does it sometimes, mostly when I go into reverse though. Sometimes it won't even let me into first without pressing the clutch in and out a couple times, then it goes in smooth. Sometimes it just makes the sound like grinding gears or something.

Sorry I'm no help on how to fix it though, mine still does it.
 

·
Registered
2.5RS Rally Car
Joined
·
2,066 Posts
if it's grinding that means the clutch is not releasing all the way. Make sure you don't have your floor mat under the pedal... happens all the time.
 

·
Meany Head
2000 RSC
Joined
·
10,236 Posts
Another thing to consider, it could also be as simple as needing to change/upgrade your trans oil. I had at one time put in some way too slick of trans oil. Can't recall what it was, but it was a high grade synth 90W. It caused 1st to grind just a little sometimes. Replaced it with some nice RedLine 75W90 NS, and it went away. With the super slick oil, my synchros didn't get enough friction to do their job. The RedLine stuff takes care of that.
 

·
Registered
02 2.5rs
Joined
·
159 Posts
mine does it too, i dont think its anything wrong with the cluth or synchros. Whenever you think your grinding your gears its actually the synchros taking the brunt.
 
1 - 8 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top