Subaru Impreza GC8 & RS Forum & Community banner

1 - 7 of 7 Posts

·
Registered
Joined
·
16 Posts
Discussion Starter #1
Strange thing happen this morning. I got in my car, started it, and started backing out of the garage when the low fuel light came on and the guage slowly fell to empty? I quickly checked to make sure I wasn't gushing fuel, which I knew was not likely, then shut off the engine.

I cycled the ignition and started the car again, fuel still showed empty and now the CE light came on!

I shut it off, grabbed the laptop and hooked it up and checked the codes. It indicated "Fuel Level Sensor Input HIGH". I then backed it out into the street and PRESTO! the fuel light goes out and the guage goes back to 3/4 tank.

I cleared the code, and all seems normal now.

Has anybody else had anything like this happen?
:confused:
Car goes in wed for the recal reprogram.

Lygriek
 

·
Registered
Joined
·
1,427 Posts
Never had that happen. Might happen soon though, after I fill up it only shows 3/4 of a tank.....never seen it go all of the way up.

Buster
 

·
Registered
Joined
·
16 Posts
Discussion Starter #3
Happened Again Today

This time while driving, I made a very hard laft at about 40mph and the low fuel light came on and the gauge dropped to about 1/4 then wnet up to 3/4 and stayed there, but I have a full tank?

I am going to check the seal around the float and see if it might be leaking or something. Both times this happened I had a full tank of gas?

Lygriek
 

·
Registered
MY00 Impreza 2.5RS, Aspen Whit
Joined
·
150 Posts
I have been having the same problem too. Now its saying like when I leave work its at 1/2 tank and by the time I get home it falls to 1/8 full. I don't work that far away.

Someone told me I probably had a bad Sender on my Fuel Pump. I never checked it out though. Just get gas more often
 

·
Registered
Joined
·
16 Posts
Discussion Starter #5
Wow!

Wow!

Its been almost two years since I posted that, don't even have the Impreza anymore, which makes me sad :( But, I do remember that it turned out to be a bed sending unit in the gas tank. I traded it in at the Mitsubishi Dealer where I worked and they wound up having to fix it, lol.

Man I wish I had my Impreza back, this Montero is KILLING me in gas.

:bonk:
 

·
Premium Member
00RS 04STI
Joined
·
953 Posts
Lygriek,

trade that thing in and come back to Subaru or Evo VIII.
 

·
Registered
Joined
·
16 Posts
Discussion Starter #7
Yeah, maybe if I wasn't sooooooooooooo buried. lol.

Besides, you ever seen one of these things airborn?

Plus, I engage the AWD and drive Bouquet Canyon like it was my Impreza.
 
1 - 7 of 7 Posts
Top