Subaru Impreza GC8 & RS Forum & Community banner

1 - 12 of 12 Posts

·
Scoobymods Guy
2010 Legacy 3.6R Limited
Joined
·
1,157 Posts
Discussion Starter #1
I've got a 99' RS and think I have to get a new front O2 Sensor. The CE code I'm getting says it's the front one anyway. (P0130) I called the local auto store and they have a Universal Bosch replacement and a Subaru one (Also Bosch I think) Has anyone used a universal one before? That one is in stock so I'd like to try it but I wanted to see if others used one first. Also is it just plug in (3 wire) or do I have to do some wiring to get it to fit?

TIA,
 

·
Scoobymods Guy
2010 Legacy 3.6R Limited
Joined
·
1,157 Posts
Discussion Starter #2
No one? Rats. Anyway, I did a lot of searching on the net and I found a place that has the OEM Bosch sensors with the right harness plug for 56 bucks and I decided to just order the right one. I hope it gets here soon.
 

·
Premium Member
95 Impreza L AWD
Joined
·
973 Posts
It's kind of late, but I'll tell you anyway. The universal sensor does not have a plug on it; just wires coming out of the sensor. However, there are a few different plugs in the box, and you find the one that fits and put it together, either by crimping or soldering(I'm not sure on this part).
Anyway, I'll need to get one soon, so can you tell me where you found one so cheap? I know it won't be the same one for my car, but that's a damn good price! Thanks!:)
 

·
Scoobymods Guy
2010 Legacy 3.6R Limited
Joined
·
1,157 Posts
Discussion Starter #4 (Edited)
Mine is on it's way as we speak. I found a good place on line that was very good with sending me shipping tracking and such. It's the first time I've used them and so far so good. it's

www.Drivewire.com

Check them out and let me know what you think.

Peaty

Cut and paste from that site

Bosch
Part# C5010-61064
Oxygen Sensor OE Connector
List Price : $ 129.95
Our Price : $54.37
Ships : Tomorrow
 

·
Premium Member
95 Impreza L AWD
Joined
·
973 Posts
I checked the price of an oxygen sensor for my car, and it's $75. I can get one locally for $88, so there isn't much reason to get it from there after shipping.:(
 

·
Scoobymods Guy
2010 Legacy 3.6R Limited
Joined
·
1,157 Posts
Discussion Starter #6
I was quoted about 70 here for one for my RS. What I did was get a gas filter and some wiper blades to make the order 100 and get free shipping. Stuff I need anyway so I figures what the heck.
 

·
Premium Member
95 Impreza L AWD
Joined
·
973 Posts
Maybe mine's more expensive since I only have one? I also found out that I can get the universal one for my car for just under $60, so I may just do that.
 

·
Premium Member
95 Impreza L AWD
Joined
·
973 Posts
Wow, your plug is completely different from mine! Mine is squarish, but only uses 3 of the 4 slots for the connection.
 

·
Scoobymods Guy
2010 Legacy 3.6R Limited
Joined
·
1,157 Posts
Discussion Starter #10
Mine only goes back to 97 yours is 95? I was happy to see that the place I got it from had the applications broken up by month and year for the one I was looking for.
 

·
Scoobymods Guy
2010 Legacy 3.6R Limited
Joined
·
1,157 Posts
Discussion Starter #11
I_H8_1.8 said:
Wow, your plug is completely different from mine! Mine is squarish, but only uses 3 of the 4 slots for the connection.
After messing with my exhaust the other day, I think you were looking at the rear O2 sensor. That one is square on mine w/ 4 slots.

also a follow up:

Well it's not quite a week since I replaced my front O2 sensor. After I replaced the front O2 sensor and the CE hasn't been back since. Also my car seems to be running much better. It idles better and just overall has a better running feel. My gas mileage appears to have gone back up too. I was getting a fair amount of carbon on the exhaust tips, more than usual. I cleaned it off the other day and so far it's still fairly clean. One thing I also noticed while I was under there is my Random Tec hi-flow cat was leaking a very little at the header and mid-pipe flanges. The leak was small but since I was blowing so much carbon it was easy to see it with the black mark it left. I took it off and put some of that high temp silicone around the seals and that seems to have solved the problem. Sealing the leaks have no doubt helped too. My car had 56K miles on it when the light started coming on. They (Bosch) says to change the O2 sensor every 60K, not sure what Subaru says though. It's the first time I've ever replaced one it was easy and now I'm glad I did. I wish I did it sooner it probably cost me almost that much in extra gas.
 

·
Premium Member
95 Impreza L AWD
Joined
·
973 Posts
I only have one oxygen sensor, but I guess the rear uses the same plug. Glad to hear it's running better-I need to replace mine, but it will still be at least a few more weeks before I can!:curse:
 
1 - 12 of 12 Posts
Top