Subaru Impreza GC8 & RS Forum & Community banner

1 - 13 of 13 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
“99 RS
Hi fellow Subie enthusiasts,
I’ve read more threads than I can count on this and I never seem to find a definitive answer.
My front indicators/hazards just stopped working the other day. But the bulbs are Still turning on as headlights just won’t blink

my indicator and hazard switch are okay I assume as my rear lights still respond when indicating/hazards.

The dash still displays the Blinking arrows and the flasher relay is ticking away so I didn’t think it could be the relay either seeing as how the back lights and dash still work ( most common cause I’ve read about ).

No blown fuses in the coin slot fuse box
No blown fuses in the engine bay fuse box and horn still works (as it runs off the same fuse as the hazard switch).

ive multimeters the front indicator bulb sockets and they both have 0.01-0.07 DCV
(Not sure what standard volts are?)

please! any help would be insanely appreciated even if it’s only a guess or something else I could test/try.
 

·
Registered
Joined
·
1 Posts
Funny enough (ha ha, eh?), same problem on my '00 RS Sedan. Side and rear indicators/hazards work, but flash a bit fast.

I'm thinking bad relay, but I'm also thinking that I'm absolutely garbage with electrical issues. Found plenty of old threads with similar issues, but didn't find solutions. Let me know if you come up with anything– I'll do the same.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #4
have you done anything recently before it started happening (removing battery, installing anything new thats power related)?
any chance you have tried replacing anything since your last message?
what Litre is your RS?

both front left and right are on seperate wires from when they leave the coin holder fuse box near my steering collum but get packing into the same harnes (front wiring harness), both are getting the required volts when they split to a joiner along the line that shares the power to the side markers which are also getting the right power, somewhere between when it splits off and hits the fronts the power is being lost. but its highly unlikely that the wires have corroded for both left and right powerleads to the front and only after the side markers splits off as it has to wrap around to the other side marker which it seems to be doing fine
 

·
Registered
1995 EZ30 Coupe
Joined
·
510 Posts
Check yo grounds, boi! Idk what else it could be. Is it only the front, or do the side markers also not blink? They seem to be directly connected. Have you tinkered with any of the wiring in the front half of the car recently?

Edit: ok read the latest, side markers work but fronts do not... Gotta be bad wires somewhere?
 

·
Registered
Joined
·
7 Posts
Discussion Starter #6
the side markers blinks and the little indicators on the bumper near the fog lamps blink. The power is branched off to them through the same cables that are suppose to supply power to the front indicators but isnt. funny thing is front left and right are seperate cables but are doing the same problem, makes me think itd have to be something they both share causing the issue

the ones that dont work are the front ones near the headlight (still functions as a headlight so the grounding for the power to the socket is fine).
 

·
Registered
Joined
·
7 Posts
Discussion Starter #7
Havent messed with any wiring,

New Sony Headunit installed about 4 months before this happened without issue.
recently Swapped Tail Lights for aftermarket about2 weeks ago n hadnt had issue
 

·
Registered
1995 EZ30 Coupe
Joined
·
510 Posts
Ok I'm a little unclear, also not that familiar with the rs bumper so that's not helping.

So the little corner light next to the headlight isn't working?
 

·
Registered
2001 Impreza 2.5RS+T 2001 Legacy GT
Joined
·
1,239 Posts
The RS front end has head lights and corner markers attached the fender. the markers in the front of the fender are parking lights and remain solid while in operation, the small markers near the rear of the fender are turn signals, they only blink. The lights next to the fog light in the bumper are turn signals and blink.

From the OP it sounds like his turn signals are remaining solid in the first position of the head light switch. You should be getting an intermittent 12v signal from the turn signal bulb sockets if they were operating correctly.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #10
The front corner lights at the front of the fender are getting 12v solid when headlights Or Parker’s are on. But little to no power during indicating. (They were definitely indicators)

side markers at the back of fender and the markers at the fog lamp blink fine but are only getting an intermittent 7v (so are the rear tail lights during indication)
 

·
Registered
1995 EZ30 Coupe
Joined
·
510 Posts
Ah, on my '95 the corner light (next to headlight, front of fender) was just a marker light, not a blinker, until I rewired it. I didn't think any first gen Impreza had indicators there from the factory, hence my confusion.

If you haven't physically checked the wires, I'd do that to make sure they're not shorting on each other. I recently had to replace the harness for one of my tail lights as it was causing some STRANGE things: Even with working bulbs, one brake light would not light, and one of my running lights would go out when I hit the brake. But all bulbs had voltage at appropriate times? Whatever, new harness fixed it.

After that try swapping the flasher module for a known working unit? I still think it's a short though.

Edit: after reading here and there, I'm pretty sure the front-of-fender corner light is not a blinker, even in the RS'. It's a marker light, meant to be constantly on. If it really was a blinker, it was a custom job, and you should DEF check the wiring.
 

·
Registered
2001 Impreza 2.5RS+T 2001 Legacy GT
Joined
·
1,239 Posts
I tried to get that point across in my other post.

the lights directly next to the head light do not blink from the factory, they remain solid in the second and third positions of the head light switch. Three lights blink on each side of the vehicle depending which way you're indicating, not four, the light in the bumper next to the fog light, and the small marker near the middle/rear of the fender blink, and of course the one on the back.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #13
I know they were indicators/hazards and when you look up “1999 gc8 subaru Impreza front indicator” it comes up with them aswell as the other indicator lights (side and bumper). Seems like only 2 years were indicators n stopped by 2000 (98-00)

regardless of that, they aren’t working now but still function the way everyone is saying they are suppose to from factory so I’ll just leave it the way it is.

I don’t know whether to call this solved or not now lmao
 
1 - 13 of 13 Posts
Top