Subaru Impreza GC8 & RS Forum & Community banner

1 - 16 of 16 Posts

·
Registered
04WRX -295whp, 03WRX Wgn stock
Joined
·
79 Posts
Discussion Starter #1 (Edited)
I just finished installing a new clutch on my '99 Impreza L 2.2L. Everything seemed to go smooth enough, but when I got it all back together and started it up I got this troubling noise. Can someone point me in the direction as to what is going wrong here. My first thought is that the starter is not disengaging, but that's just a guess, I don't really know whats going on here.

 

·
...Lower it
01 Aspen Ej205'd RS
Joined
·
7,010 Posts
How does it shift? I mean stationary if you push the clutch in does it go through the gears?
 

·
Super Lurker
00 RS Black 4dr /w broken bits
Joined
·
95 Posts
Could it be the metal dust shield at the bottom got bent a little and is rubbing on the flywheel/pressure plate maybe?
 

·
Registered
2001 Impreza 2.5RS Sedan
Joined
·
643 Posts
Is the flywheel rubbing on the little metal plate on the bottom of your bellhousing?

It sounds "thinnner", that's what made me think of that...

Oh yeah, what ^he^ said as I was typing mine :)
 

·
Registered
04WRX -295whp, 03WRX Wgn stock
Joined
·
79 Posts
Discussion Starter #6 (Edited)
Could it be the metal dust shield at the bottom got bent a little and is rubbing on the flywheel/pressure plate maybe?
Is the flywheel rubbing on the little metal plate on the bottom of your bellhousing?

It sounds "thinnner", that's what made me think of that...

Oh yeah, what ^he^ said as I was typing mine :)
So I crawled under the car to check things out but couldn't really see much as that dust cover is right above the engine crossmember. With the car running the sound is louder underneath and seems to be coming from the area of that dust cover.

So next question how do I get to it to bend it back? I really don't want to have to pull the trans all over again.
 

·
Registered
Joined
·
92 Posts
If I remember right, there should be a large enough gap to fit a screwdriver or something else and get a little leverage to bend it back...or at least get in and feel if it's touching.
 

·
Registered
2001 Impreza 2.5RS Sedan
Joined
·
643 Posts
See if you can remove that shield . It's two 10mm
I believe there is room to get a wrench in there to do it without removing anything. (I forgot to install it once on a clutch job, pretty sure I put it on without pulling anything).

If the noise is gone after you pull it, that's your man. Inspect it and see what is chewed on and "adjust" as necessary...
 

·
Registered
04WRX -295whp, 03WRX Wgn stock
Joined
·
79 Posts
Discussion Starter #11
Well I got the dust shield bent back. I had to pull the trans again to get to it. Putting everything back together, and now I can't get the trans corssmember to line up with the car. Will nothing go right during this install!?! :curse:
 

·
Registered
Impreza 2.5rs
Joined
·
745 Posts
It's never just an easy job. You have go in expecting oddball ****, busted/stripped bolts, wrong parts, injuries, etc...

Its a PITA no doubt, but far better than the alternative.
 

·
Registered
Impreza 2.5rs
Joined
·
745 Posts
I hate finding a thread thinking it will help solve my current problem just to find out it ends with me posting that shits gonna go wrong. :(

Kinda funny in a way though.
 

·
Registered
00rs and 97 GF8 L wagon
Joined
·
802 Posts
maybe a bolt felt in there or the dust shield is bent which might be rubbing the flywheel, or install the dust shield wrong way if that's even possible.
 

·
I kill threads!
2000 Ver 6 STI - 1996 Gravel Express
Joined
·
3,749 Posts
This thread if over a month old, I'm sure they already fixed the issue.
 
1 - 16 of 16 Posts
Top