Subaru Impreza GC8 & RS Forum & Community banner

1 - 10 of 10 Posts

·
It's not a GC
07 WRX Wag0nz
Joined
·
9,387 Posts
Discussion Starter #1 (Edited)
Ok! you guys here is the Deally' yo' the only engine mods that I have on my ride are Weapon R intake (Soon to be Injen Cold Air Intake) and an A'pexi N-1 exhaust which by the way is great!! I can really feel the difference anyway...the only problem that I have is that I'm back firing a lot and this seems to be getting louder and louder, is this normal??? for those of you who have exhausts are you guys experiencing the same thing? I thought that this might be casued by the type of fuel I use which is 89 or better no 87 I think the only time I've used 87 is about 3 months when I could not afford to do anything...anyway could this be a good reason why I'm back firing anyway...for all you Thread Stealing Fools out there (Richard!!!!!!!):curse: :biggest: :happynow: if you are planing on stealing my thread please do so in style and stay on TOPIC!!!!!! :curse: anyway Sean! any input???

--Frakk--PutIn' dEez iN yO' MoUfF...
 

·
Registered
Joined
·
377 Posts
Frank,

The backfiring can be due to the design of your muffler. I have never had any backfiring with my Weapon R Stromung combo running 87. I have been running 87 for a year with no problems. Also backfiring can be caused by plugging in the wrong spark plug wire to a cylinder.

Val


THe KING OF SCIC
 

·
Registered
Joined
·
9 Posts
Are you sure its backfiring and not just popping?
Popping (could be mistaken for backfire) happens because cold air goes into the exhaust from the outlet due to increased pipe diameter and decreased exhaust flow (off throttle), mixes with unburnt fuel and *VIOLA* POP!

Just a thought.

Ryan

edit: my GReddy exhaust does it all the time too.
 

·
Registered
Joined
·
1,133 Posts
FRAKK's2.5 said:
for all you Thread Stealing Fools out there (Richard!!!!!!!):curse: :biggest: :happynow:
ME?!?!? I don't know what you're talking about!


Actually, I'm looking at getting a CAI and cat-back exhaust soon, too, so I am reading through tons of posts on the subject. Seems it's not that uncommon when you let off the gas to have some of those "backfire" sounds. Dunno if that's what you're hearing.

SEE! I can stay on-topic!
 

·
Registered
Joined
·
2,332 Posts
My car pops all the time, I think it cool, kind of like an anti-lag system on a rally car!!!!!


Really, Ryan is most likely right. It can also be caused by a small leak in the system.

Talking about thread hijacking. I can't get into the forums at the I-club. Is it just me or is there a problem?? Could fishhead have locked this IP address???
 

·
Registered
Joined
·
1,133 Posts
What error message did you get? I can get on fine. Sometimes i-club gets pretty backup up and you can't get on. Either that, or they had enough of your trolling :eek:
 

·
Premium Member
Two Mini Coopers!
Joined
·
10,629 Posts
I-Club was down last night, as I am sure you all know by now... software and hardware upgrades apparently... Cool! :)
 

·
It's not a GC
07 WRX Wag0nz
Joined
·
9,387 Posts
Discussion Starter #8
ryaneatworld said:
Are you sure its backfiring and not just popping?
Popping (could be mistaken for backfire) happens because cold air goes into the exhaust from the outlet due to increased pipe diameter and decreased exhaust flow (off throttle), mixes with unburnt fuel and *VIOLA* POP!

Just a thought.

Ryan

edit: my GReddy exhaust does it all the time too.
You know what you are right I might be mistaken the Poping and Backfiring, I guess that answer my question I guess all of the input you guys gave me make sense Thanks....

Obsidian...I knew you had to throw in your two cents

Thanks guys!!!!:happynow:
 

·
Registered
Joined
·
1,133 Posts
FRAKK's2.5 said:
Obsidian...I knew you had to throw in your two cents
TWO cents?? TWO whole friggen cents?? My words are worth more like 2000!

(well 2000 pesos, at least!)
 

·
Registered
Joined
·
2,332 Posts
On the i-club matter.......I was origanly getting a messange about my ip not working to get in, then later it came up with the down for upgrading message. I tryed again this morning from my house and it worked fine.
 
1 - 10 of 10 Posts
Top