Subaru Impreza GC8 & RS Forum & Community banner

941 - 960 of 2558 Posts

·
They call me Garrett
98 RBP V4 STi Swapped RS
Joined
·
4,088 Posts
Discussion Starter #942 (Edited)
Because I want to experience a stock STi before I decide I want something better. Also the coils I would want cost 10x more than what STi struts and springs would cost, and I hate settling.

In my opinion people just toss on way too many things on their cars just because other people said they "were good". While they may be right, in reality most people put on suspension parts and go around a turn at 25mph and say, "OH MANY WHAT A DIFFERENCE COLIN MCRAE COULDN'T HAVE MADE A CAR HANDLE THIS WELL!" when really literally nothing has changed, they don't even know what the parts WOULD change, they don't push the car hard enough to notice a change, or it's been made worse.

People also toss on parts and compare them to something that is broken or way past it's prime. To me that doesn't seem quite fair, because of course things like bushings that have done 250k miles will be worse than random aftermarket ones that are brand new.

Start from a good base, and work your way up from there. OEM STi > OEM RS, that is one thing I can know for certain right now.
 

·
They call me Garrett
98 RBP V4 STi Swapped RS
Joined
·
4,088 Posts
Discussion Starter #943
"OEM" Keyless Entry

Finally found a remote for a decnt price that wasn't completely trashed and broken.

Tossed the box and everything in.

It works...poorly. Stupid poorly designed dealership options. Oh well, scene points! Need to get an OEM mount since I'm pretty sure I tossed mine when I took this unit out of my old RS.





 

·
Premium Member
2001 Subaru Impreza L coupe
Joined
·
773 Posts
If you need the mount part for under the dash you can have mine....I did the opposite and removed all my keyless entry stuff, so I don't need any of it.
 

·
Registered
'01 RS '06 WRX swapped
Joined
·
297 Posts
Replace the battery in the keyfob and snake the antenna around and it'll work better :)
 

·
They call me Garrett
98 RBP V4 STi Swapped RS
Joined
·
4,088 Posts
Discussion Starter #949
Whelp, tank install was not a complete success as of right now.

Got to a 3/4 of a tank today for the first time since the tank install and I started to misfire like crazy. Thought it may have been the OEM alarm system.. it had started to sound the alarm (really just blinking my lights because i don't have the it hooked up to the horn) while i was sitting with key in the Acc position today waiting for someone. Pulled the box out, and still having issues.

Car only misfired between ~2-2.5k RPM and (shitty gauge indicated) 5-10 inHg. It pulled just fine through 3-8k at WOT.

I decided to fill the car up to full again to see if there was a problem with the fuel sender. Maybe the rubber line i added in wasn't tight enough, or something. Sure enough with a full tank no misfiring. Did a 5th gear, 2k RPM WOT pull, so full load on everything, and it ran great.

I also had a LOT of pressure in the tank. Hisses whenever I pull the cap off after driving.. so that could be an issue too. Maybe I did a dumb and connected the fuel return and evap lines to the wrong hoses at the back of the car :eek: ... if that's even possible to run like that.

I really do think it's rubber line on the sender. That would also explain why the car felt like it was out of gas after I had just put over a 1/4 tank in it right after the tank installation.

So. What I think is the issues could be:


  • Top (any bottom maybe) of the rubber line from the fuel pump to the sender is cracked, or not making a proper seal. I did just reuse some hose line from the tank, so I definitely wouldn't doubt it.
  • Evap lines not plumbed properly and tank is drawing a vaccum
  • Combination of the two.
I'll start messing around when the car (or the outside temp, freakin' humid) cools off.



Little issues after a big job, no worries here :)
 

·
They call me Garrett
98 RBP V4 STi Swapped RS
Joined
·
4,088 Posts
Discussion Starter #950
Hahaha.. well that was pretty easy to figure out..


Evap and fuel return swapped.

Also gonna get some better fuel hose for the sender. Don't think that is also an issue, but i don't quite like how it's sitting in there. I have it sitting out in my garage, might as well beef er' up.
 

·
They call me Garrett
98 RBP V4 STi Swapped RS
Joined
·
4,088 Posts
Discussion Starter #951 (Edited)


New sender "setup".

More rigid and bulky hose. New clamps, and a ziptie for good measure to secure it all. Fuel returns to the right place and the car starts. Only time will tell if it's fixed. Give me half a tank or so haha.
 

·
They call me Garrett
98 RBP V4 STi Swapped RS
Joined
·
4,088 Posts
Discussion Starter #956
Lookin' good!
looks great! Are you doing bodywork to the other side soon?!
agreed, looks good g :D
Thanks guys!

And yeah side should be getting done soon. I might run out of time to get it done though. Gotta be back at school at the end of the month. GRR!

Also fuel tank update:

Less than half full now, no issue whatsoever. I solved it. Also didn't hit fuel cut ripping it through an onramp, so I think progress was made!
 
941 - 960 of 2558 Posts
Top