Subaru Impreza GC8 & RS Forum & Community banner

421 - 440 of 2548 Posts

·
They call me Garrett
98 RBP V4 STi Swapped RS
Joined
·
4,075 Posts
Discussion Starter #421
I got the front V4 suspension with the clip, but didn't put it on because i didn't want to mismatch the rears.

Stock RS struts and springs with STi sways. Awesome DD setup but i'd like to get V6 STi stuff.

Also running with All-Seasons haha.. those are no good. Yokohama Avid ENVigors

I want to get some higher offset wheels and stickier tires along with that V6 suspension.
 

·
They call me Garrett
98 RBP V4 STi Swapped RS
Joined
·
4,075 Posts
Discussion Starter #422
So here's the venting system the V4 STis had..



To my understanding:

Blue = Pulling vapor from tank, and well as replacing with fresh air
Red = Pulling air from intake into canister
Green = Pulling air and vapors into throttle body to be used

As far as i know i only have the Red an Green things hooked up, and then the things at the tank are for the RS.. which.. in all it's complexity need to just be gutted and removed, and then lines run to the tank.

Things i have from the clip but are not on the car:



The lines that go to the tank and come into the canister at the bottom. I have these, but they are not on the car at the moment. They go down into the trans tunnel, and then cut across the trans x member and i assume go to the tank somewhere from there but were cut with the clip. I can fab up something for that.

The other two lines are connected on the canister.

If i take all the RS crap off, and route those lines correctly i SHOULD have the proper venting system.

I also picked up this:



Looks like it'll bolt up 100% but i guess i'll find out.

All of this stuff combined, fuel cut issues in turns should be my least concern.
 

·
They call me Garrett
98 RBP V4 STi Swapped RS
Joined
·
4,075 Posts
Discussion Starter #426


Whelp.. i feel like an idiot.

Tried to put it in today... and it doesn't fit... and i guess people had said it doesn't fit.

Time to source an 04 STi gas tank, as i need to drop the tank anyways.

Good news is that i CAN confirm the connections are the same and the sender WILL work. But everyone probably knew that already.
 

·
They call me Garrett
98 RBP V4 STi Swapped RS
Joined
·
4,075 Posts
Discussion Starter #428
I have in fact, which is where i got the initial idea to snag one of the GD STi sender units from... though looking through the thread a couple minutes ago people said the surge box wouldn't fit in the GC tank. Which is why i feel stupid because i just jumped on getting this without researching enough.

I need to drop my tank to fix some venting issues anyways, so i figure i'll get the bigger tank that'll fit the GD unit anyways.
 

·
Registered
99 rustbox
Joined
·
1,041 Posts
untuned and you are doing that? wow im a bitch. My 20k hasnt seen over 5k yet I am scared to give it any, maines fuel is shit though....

Can you do me a favor and take a video of a cold start up for you? or at least what just lemme know if you get any knock. I am getting some gnarly rod knock on my cold starts... once the engine gets up to temp it goes away. Maybe has something to do with the forged pistons?
 

·
Banned
03 Legacy GT wagon
Joined
·
6,471 Posts
untuned and you are doing that? wow im a bitch. My 20k hasnt seen over 5k yet I am scared to give it any, maines fuel is shit though....

Can you do me a favor and take a video of a cold start up for you? or at least what just lemme know if you get any knock. I am getting some gnarly rod knock on my cold starts... once the engine gets up to temp it goes away. Maybe has something to do with the forged pistons?
mine had the same thing, its the start of rod knock. i revved mine to 7000-7500 for almost 2 years, and it was fine with the same knocking noise on cold starts (stock jdm ecu), and no problems until i decided to take it to the drag strip and rev it consistently to 8200+ and it destroyed a bearing finally
 

·
They call me Garrett
98 RBP V4 STi Swapped RS
Joined
·
4,075 Posts
Discussion Starter #439
Here's a cold start video for ya :)


Lil accessory belt chirp because it's been raining for the past 4 days haha.

Also did a bit of lazy work (read: small things i've been meaning to do but haven't) today.


  • Fixed crappy rep lip sag - took out the crap hardware and just used zipties, looks gobs better.
  • Fixed the bumper sag on the passenger side - just needed to tighten up some bumper beam bolts
I also started running the stock evap lines to the extent that i could. I only have the lines from the trans forwards, and i have no idea where they need to go past that.





Using the stock mount up front as i could reach in the clip's frame to pull it out... not so much with the other one. Looks to me like it's being run correctly as it can be on a LHD car.


Will post more once i get it completely sorted but i figure i may as well do what i can now.
 

Attachments

421 - 440 of 2548 Posts
Top