Subaru Impreza GC8 & RS Forum & Community banner

221 - 240 of 2577 Posts

·
They call me Garrett
98 RBP V4 STi Swapped RS
Joined
·
4,103 Posts
Discussion Starter #221
Dang Equinox, looking good! That sucks about the heater box though :/ that damn plastic hose! Everything else is looking good though! Are you going to keep the A/C Compressor connected the whole time and just bolt it on when the 20k is in? Or will you take it off?
Had it all connected to save the AC charge in it.. but then i remembered i had to pull the HVAC, haha. But yeah, i plan on using the 251 AC compressor with the 20k because the 20k one looks to have different inlets for the LHD AC lines. Not sure if it'll bolt right up but i can swap mounts over and grind one down or whatever. I'll make it work.

do you think you could epoxy the pipe you broke off?
Already have a spare on the way :) Though i did think about JB weld... but i didn't want to have to do that. If the part isn't here by the time i want to start the motor, i'll just bypass the HVAC for the time being and connected the two lines together on the motor.

Going to go run the JDM ECU lines in car just to get a measure of how much i need to trim them and such. Then pulling out the harness and beginning the merge. The father borrowed a nice brand new heat gun and some shrink wrap from his workplace so I'm ready to break her in.

Updates and pictures and such later tonight!
 

·
Registered
99 rustbox
Joined
·
1,041 Posts
while ripping my dash apart for my swap (yesterday), i broke the exact same thing... i think a junkyard visit should fix everything lol.
 

·
They call me Garrett
98 RBP V4 STi Swapped RS
Joined
·
4,103 Posts
Discussion Starter #224


EJ251 harness all labeled up and ready for the merge. Only one wire doesn't seem to match up to the diagrams so i need to buzz it out, it's the main fan relay, just says it's a different color than what i see on the harness.

Let the cutting begin.
 

·
They call me Garrett
98 RBP V4 STi Swapped RS
Joined
·
4,103 Posts
Discussion Starter #228 (Edited)
Wiring is almost done!

Few 12V and grounds to be made and then tape! Just going through everything with a fine comb.

Have the engine bay pretty much settled, though i do need to run a few more connections through a boot on the 251 harness. Left side is completely hooked up and set to go though.

Pictures of all this:



No going back now.





Just to show that i am soldering things correctly, using heat wrap, and all that good stuff, hah.



Blue tape is just on there to keep thing organized, will be replaced with 3M stuff later.



Engine bay routed minus shrinkwrap and tape.

20k should be in tomorrow, possibly running. Fingers crossed.
 

·
They call me Garrett
98 RBP V4 STi Swapped RS
Joined
·
4,103 Posts
Discussion Starter #229
Oh just remembered.. how the hell am i supposed to mount the ECU?

The brackets are spot welded on for RHD mounts (which don't fit in) on to the ECU case, and are backwards to the LHD stuff.. and i don't really just want to leave it hanging there.
 

·
Registered
A Blue RS
Joined
·
2,975 Posts
Oh just remembered.. how the hell am i supposed to mount the ECU?

The brackets are spot welded on for RHD mounts (which don't fit in) on to the ECU case, and are backwards to the LHD stuff.. and i don't really just want to leave it hanging there.
Are the ecu cases the same size swap the boards?

-crash
 

·
They call me Garrett
98 RBP V4 STi Swapped RS
Joined
·
4,103 Posts
Discussion Starter #239
More wires. No boost yet.

That's alright though.

Redid the fusebox to accommodate two extra relays for the STi radiator.







It's a tad messy, but it will go alright.

Also got the left side all taped up and set to go.



Few more connections made in the interior, tomorrow i'll start powering everything up one by one.
 

·
They call me Garrett
98 RBP V4 STi Swapped RS
Joined
·
4,103 Posts
Discussion Starter #240 (Edited)
She made it in okay!







Swapped over the RS alternator and A/C + brackets as it's wired for those.

Right now dealing with a bit of a power steering issue.. the connection coming from the RS PS pump look like so:



And the STi ones like so:



The rack is a male connector.. so i can't use the STi lines for sure.. though i also don't think i can use the RS pump on the 20k.

Was thinking of swapping out lines only, keeping the STi pump and making it work.. return lines seem to be the only issue and they are low pressure so it shouldn't be a HUGE deal... anyone know anything about this?

After i figure that out, and tidy up some wiring (still leaving most of it open until i get a confirmed start and drive!) it's go time!

Oh and cruise control... can i make it work with a downpipe where the actuator should be.. haha. Was thinking about fabbing some mounts just to move it either above the DP, or tucker more into the bay where it normally sits, any thoughts?
 
221 - 240 of 2577 Posts
Top