Subaru Impreza GC8 & RS Forum & Community banner
1 - 6 of 6 Posts

·
Registered
01 RS & 97 L
Joined
·
590 Posts
Discussion Starter · #1 ·
ARG!! man it totally sucks and I just want to right about it I guess.
So I got these Delta cams a while back ago and I used their cores, so that means I have a core deposit on them. that's $200 laying around in my garage.
and I have been wanted to tackle this project for a while, I finally found enough time to do the cams. I started last night. taking the intake off. I thought I might as well paint it while its out. that wasn't that hard. cleaned them painted them and junk. then I woke up this morning with the mind set to fully devote this day to cams. every thing was actually going kinda smoothly. Took a while for me to get the crank pulley out. so I am working I get down to the step right before the cams come out. I noticed I forgot one thing, that liquid gasket thing, and I came so close to stripping one of those hex bolts inside, and I was like ok that's it. I can't go any further. there was nothing I could do, that thing did not want to spin and I the bit kept slipping. and even if I could get it out, what size are those hex bolts outside the valve covers. its like between a 5mm and a 6mm hex. I still didn't have liquid gasket but I could always go and get that. so I had to work backwards and get every thing back in.
All day spent in a garage with no reward...
Everything went back in, but I did forget the routing of some of the cables and junk so it looks janky in some places and I have a few "extra" stuff that didn't go back in.
but the good news is that there where no CELs and the car ran like normal when I got it all back together. I am going to call up a shop and see if they can take my car first thing in the morning.
yup that was my day:(
 

·
Premium Member
overdeveloped beater
Joined
·
8,335 Posts
You talking about the Torx-Plus bolts? They take an IP40 bit. A regular T-40 will only barely get them....and most times round off inside. The socket head capscrews are 5mm.

When I broke my heads down, I used:
Sockets:
10mm, 12mm, 14mm
Hex drivers:
5mm
Special drivers:
Torx-Plus size IP40
 

·
Meany Head
2000 RSC
Joined
·
10,236 Posts
Bingo.. Storm speaks the truth. The Torx-Plus 40 is what you need. It's a little tricky to find one, but they exist. I had to call my local SnapOn dude to get one. McMaster Carr sells them too. Forget about going to Sears, they don't stock them.
 

·
Premium Member
overdeveloped beater
Joined
·
8,335 Posts
I've got an extra IP40 torx-plus driver. 3/8" drive for your ratchet set. It cost me $10 iirc.....made by Wiha. I bought 2 in case someone needed one......PM me if interested.
 

·
Registered
01 RS & 97 L
Joined
·
590 Posts
Discussion Starter · #6 ·
I wish I could at the moment, but I need to pay off some debt before I go for attempt number two. and I think I might have set it back up wrong. I lined up the marks and stuff, but I feel my car sounds differently and is behaving differently then before I did this. I have the borlas with a cat delete pipe and a cat back with an N1 in the back, but it sounds more chunky, and not in a good way. and it feels laggy-er and I am still N/A. hmmm?
 
1 - 6 of 6 Posts
Top