Subaru Impreza GC8 & RS Forum & Community banner

1 - 9 of 9 Posts

·
Registered
01 coupe
Joined
·
279 Posts
Discussion Starter #1 (Edited)
My old battery died, had aaa swap in a new battery while doing so they had me turn on my high beams and a/c and fog lights and rev to make sure everything was reading fine. After that I turned off the car thinking, ok everything is ok now. Later I turned on the car again to let it run for a bit and noticed that I had put the lights back to normal but still dash says high beams are on when they really weren't . Also my right light didn't turn on. When I actually pulled the light to the high beam they both turned on but not high beam, instead it was low and dim :( don't know what's going on. Sorry for the long explanation
 

·
Premium Member
2001 A.W. L
Joined
·
13,249 Posts
when there is a short in the headlight wiring thats what happens. Likely that the plug is melted (happens if you use more powerful headlights, and even stock brightness ones)

http://www.rs25.com/forums/f105/t100608-diy-headlight-plug-replacement.html

you can also try unplugging the bulb and plugging it back in, or wiggling it. You will see it should fix itself momentarily
 

·
Registered
00'RS/02' WRX stgEleventy
Joined
·
2,144 Posts
Do you have a trailer pig on the car in the trunk?

Sounds like what happened when I found mine in a puddle in the trunk..

Sent from an other planet (Tapatalk)
 

·
Registered
01 coupe
Joined
·
279 Posts
Discussion Starter #8
Update: noticed the interior lights that show a/c and radio have dimmed and coincidentally as the front right light not working the rear right reverse light doesn't either. What can this be
 
1 - 9 of 9 Posts
Top