Subaru Impreza GC8 & RS Forum & Community banner
1 - 7 of 7 Posts

·
Registered
Joined
·
66 Posts
Discussion Starter · #1 ·
I'm having a problem with my battery dying in about 1 hour of driving, I have tested the battery and alternator (good) and also both brand new. So the alternator is not completeing its route to the Battery. Any suggestions before I turn this into the shop? It could have been easy for me and a few others to easily look something over.

Any reply would be highly appreciated

Thanks,

Max
 

·
Premium Member
Two Mini Coopers!
Joined
·
10,629 Posts
Check that your starter motor solenoid is disengaging all the way. If the gear stays engaged while you drive, you will most likely not notice it. However, that will definately drain your battery.

Other causes: Amps not turning off, bad ground (not charging), loose wire from alternator to battery, corrosion.
 

·
Registered
Joined
·
66 Posts
Discussion Starter · #4 ·
No Stalling...

The car will drive fine for about 45 minutes. All lights on, CD player on, etc.. then the turn signals will shut stuff off like CD player, then radar detector. Then the tachometer goes. It may be the starter because the last few months it has been weary to start, not as if it will not start but sometimes it took a few turns, and sometimes it will start right up.

Thanks again for any replies

Max
 

·
Registered
99 2.5 RS-T
Joined
·
838 Posts
Is the battery actually dead after this happens or is the car just not re-firing? It almost sounds like an ECU malfunction. My battery DIED just yesterday and after it was jumped I was running on the alternator. Everything worked fine (although I did shut off the AC and radio just to be sure I'd make it to autozone). There shouldn't be a situation where things shut down individually, as they all need about the same (+12v) juice to run. hmmm very interesting.
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top