Subaru Impreza GC8 & RS Forum & Community banner

1 - 6 of 6 Posts

·
Registered
99 2.5 RS-T
Joined
·
838 Posts
Discussion Starter #1
Well, finally got the E-Manage installed (what a PITA) and now its back on my shelf :curse: . Well, I set the jumpers and the rotary switches per the Yahoo Group instructions but the silly thing thought it was a Toyota with a MAP sensor. Hmmm, interesting... So I get brave and decide to try to start the car... I got starter but no spark. :curse: Now I'm really pissed so I disconnect the ignition harness and voila, the car starts and idles well. The E-Manage was lighting up like a christmas tree b/c the ign harness was no longer connected. So, before I took the thing out on the road, I decided to remove the whole unit and try to re-group. Anyone that can help with the correct settings please do.
 

·
Registered
1999/2017 RSTI
Joined
·
221 Posts
dammit...

so are you just going to wait and see? or will try to brave another try...


:curse: GREDDy
 

·
Registered
Joined
·
852 Posts
Bill, you couldn't get it to work??

Yes, I'm back, but in FL. I'll be in TX on the 10th, and will willingly lend a hand if you don't have it fixed by then. The Link has arrived.


Graham
 

·
Registered
99 2.5 RS-T
Joined
·
838 Posts
Discussion Starter #4
It worked... sort of. There are 3 rotary switches on the circuit board and 7 jumper settings. I was going off of 00-01 RS install instructions and think they are wrong (or a different software version... don't know). Either way, the switches determine number of cylinders, air flow metering type and probably ign or tps type. Too bad GReddy wont release what each setting actually equals, then it'd just be a matter of looking it up in a chart. That being said, I'm getting some mixed info that gives me some more choices for settings, and I wired in the Emanage with Posi-Locks so re-install should be pretty straight forward. I've also got a guy on the Subaru Emanage group who offered to look at his settings and send em too me (he's got a 99 RS also).

So close!!!:bonk:
 

·
Registered
Joined
·
852 Posts
Well, I'm sure you will get it figured out soon, not to worry.

Man there is so little support for the E-Manage its not even funny!


Graham
 

·
Registered
99 2.5 RS-T
Joined
·
838 Posts
Discussion Starter #6
Graham, I won't be putting it back in until I'm confident in the settings. Next project... find all the nuts/bolts that are missing off of the turbo... which I just got in the mail, and I just picked up the IC/BOV from FIS today :D
 
1 - 6 of 6 Posts
Top