Subaru Impreza GC8 & RS Forum & Community banner
1 - 6 of 6 Posts

·
Registered
99 2.5 RSTI Army Rock Metallic
Joined
·
86 Posts
Discussion Starter · #1 · (Edited)
Hi guys,

So I've been searching and I can't really find any recent threads with functional pictures. I found this diy but the op edited it and there's no info in it http://www.rs25.com/forums/f105/t176183-diy-power-locks-99-01-rs-without-keyless-entry-box-manual-drivers-side-fix.html.

Apparently my RS came with the OEM keyless entry but the previous owner put in an aftermarket alarm and now the drivers side doesn't unlock/ lock. I'm not too sure what the oem keyless entry module looks like so I don't know if it's still under the kick panel.

I originally thought it was the door lock actuator but when I put the drivers side actuator to the passenger side it worked fine. I also put a multimeter to the female connector on the drivers side and it's only putting out 3-5v when I press the unlock/ lock button on the interior. I found out that there's a jumper or something in the RS's that don't come with the keyless entry option that's why my drivers side lock isn't operating.

Does anyone have any pictures of where I need to connect this jumper, what wires I need to hard wire for the drivers side to put out enough juice to trigger the actuator? Or maybe even the keyless entry module and it's connections?

I ended up taking out all of the after market alarm as it was spliced in all retarded and the keyless entry remote didn't even work for the either door. I'm fine with just using the keys to unlock the doors from the outside but I would like the switch on the interior to unlock/ lock both doors when pressed.

My ocd is really driving me crazy over this, any help would be greatly appreciated!

Thanks!
 

·
Registered
99 2.5 RSTI Army Rock Metallic
Joined
·
86 Posts
Discussion Starter · #3 ·
Haha you know what, after a little more digging around I found that post and another one with a different picture. That's very interesting that the jumper location is on the obd2 port area I would think it would be closer to the module somewhere.


I'm going to give it a try when I get home from work today.

Thanks!
 

·
Registered
99 2.5 RSTI Army Rock Metallic
Joined
·
86 Posts
Discussion Starter · #5 · (Edited)
UPDATE: So I connected the 2 pins shown in the picture above and it worked like a charm, I just trimmed the paper clip down to fit perfectly and then taped the whole connector head up with electrical tape.

So for anyone interested just follow the 2 pictures I found above and it should work.

Thanks everyone!
 
1 - 6 of 6 Posts
Top