Subaru Impreza GC8 & RS Forum & Community banner
1 - 6 of 6 Posts

·
Registered
97 Brighton, 4x4
Joined
·
1,681 Posts
Discussion Starter · #1 ·
So I officially cannot go 100 miles without this stupid evap control CEL. It sucks but my question is under what conditions does a CEL change the fueling? This CEL doesn't have anything to do with the performance of the vehical it just means the gas tank isn't holding pressure. I haven't been able to notice a change in millage but it seems to run crappy when ever it's on.

Any ideas??
 

·
Registered
95/99 Brighton STi
Joined
·
2,945 Posts
I'm sure it will affect gas mileage but it will be minimal...almost unnoticeable. Your EVAP system won't function correctly because the pressure sensor isn't getting accurate readings... do you know where the leak is??

I've got a CEL for a faulty rear o2 sensor heater circuit.... just means it takes longer for my rear o2 sensor to warm up... still getting high 20's for gas mileage
 

·
Registered
97 Brighton, 4x4
Joined
·
1,681 Posts
Discussion Starter · #3 ·
I'm sure it will affect gas mileage but it will be minimal...almost unnoticeable. Your EVAP system won't function correctly because the pressure sensor isn't getting accurate readings... do you know where the leak is??
I don't know were the leak is. I know the gas tank doesn't hold pressure because it doesn't make any when opened after a long period of time. You know that psssshhh sound? I don't get it.

I have yet to replace my gas cap though. I need to get on that.
 

·
Registered
95/99 Brighton STi
Joined
·
2,945 Posts
yea, gas cap is what I was going to suggest. Borrow one for a day or pick one up at a salvage yard, clear the code(reset ecu, disconnect neg bat terminal, ect) and see if the code comes back... make sure you have a good amount of gas in the tank when you do it too
 

·
Registered
97 Brighton, 4x4
Joined
·
1,681 Posts
Discussion Starter · #6 ·
yea, gas cap is what I was going to suggest. Borrow one for a day or pick one up at a salvage yard, clear the code(reset ecu, disconnect neg bat terminal, ect) and see if the code comes back... make sure you have a good amount of gas in the tank when you do it too
How come the code doesn't reset with a ECU reset. Ive tried the whole unplug brake thing and it's always still there after I do.
 
1 - 6 of 6 Posts
Top