Subaru Impreza GC8 & RS Forum & Community banner

381 - 400 of 408 Posts

·
Registered
Joined
·
6 Posts
if you do the swap you abs and cruise control won't work, unless you get a manual harness to be swap, I did mine swap and the abs md cruise control deleted
there is no way to keep abs? the guy I got my swap from handed me his harness and the manual abs from his bugeye. I have a 2000 sedan.
 

·
Registered
1995 EZ30 Coupe
Joined
·
799 Posts
^That is correct. The giveaway is the little (mt), indicating the manual harness, in which the line goes straight from power supply to the relay.
 

·
Registered
Joined
·
105 Posts
Thanks soco! That's what I was thinking but don't want to end up wiring the wrong thing.

Another question. I've run into a problem where my diff cover studs don't thread into the jdm 4.44 diff cover. Anyone know the thread sizes for the jdm diff cover?
 

·
Registered
Joined
·
105 Posts
Okay so the studs I have are off of the "old" style R160. Took the studs to the hardware store and bought an m12 x 1.5. Didn't work though go figure. So that eliminates m12 x1. 25 and m12 x 1.75 and m12 x1. 5. So what are my options?

I was hoping I could just replace with some bolts but can I use the studs off of a wrx in the mean time?
 

·
Registered
1995 EZ30 Coupe
Joined
·
799 Posts
That's interesting. Any chance the threads on your diff cover are damaged? I would've thought it was the same stud for anything other than possibly R180 diffs.
 

·
Registered
Joined
·
105 Posts
Ah I forgot I put this here. It was the 12 x 1.25 I was trying to thread them in having the diff in position and it wasn't working. So I put them on first.
 

·
Registered
94 Legacy L
Joined
·
14 Posts
I am in the process of doing this for an 07 wagon. I have a complete 07 sedan donor car, so my question is if I swap the whole harness, would I need to swap gauge clusters as well?

Also if I swap the harness would I still need to jump the wires to remove key from the ignition?
 

·
Registered
1995 EZ30 Coupe
Joined
·
799 Posts
I'm confident you won't have to swap clusters, but why wouldn't you? It'll get rid of that nasty shift light tree thingy.

Oh, mileage. Right. I usually don't care personally, but I believe there's a way to reprogram them to display the correct mileage.

If you swap the entire harness, no cutting or splicing should be necessary, unless you're trying to add wagon features to a sedan harness, maybe.
 

·
Registered
94 Legacy L
Joined
·
14 Posts
SoCoNoHa, that is what I figured as well. Only reason I'm thinking of keeping the same cluster in the car is new car has 150,000 on it where as donor has 220,000 on the cluster
 

·
Registered
Subaru Impreza EJ20 MT 4x4 98/99
Joined
·
7 Posts
Hey guys!

Just did the swap on my 98/99 AT 4x2 to 5MT 4x4 and it works very well, no issues with starting and the car runs fine but I have issues with the speedometer which is electrical and we install an older transmission which uses an analog connector.

Any tips on how to do the wiring? I guess I need this connector but how can I wire to the TCM or ECU?

82365
 

·
Premium Member
White Lwag
Joined
·
1,023 Posts
1-iwire
2-manual harness
3-research (+ wire -wire signal to speedo)

I've tried 2 and 3couldn't get it to work. Next for me is keener.
 

·
Registered
Subaru Impreza EJ20 MT 4x4 98/99
Joined
·
7 Posts
You have to get an MT speed sensor for a 99. That is the easiest solution.
Cool, that's the easy part and I already find it on RockAuto but where and how I connect this sensor?
The automatic has a bunch of cables with a plug that connect directly into the ECU (or TCM I'm not sure), but this sensor doesn't come with any cable
 

·
Cluster Specialist
1999 Impreza RS - WRB
Joined
·
497 Posts
Cool, that's the easy part and I already find it on RockAuto but where and how I connect this sensor?
The automatic has a bunch of cables with a plug that connect directly into the ECU (or TCM I'm not sure), but this sensor doesn't come with any cable
There is an extended cord that is supposed to connect to it. Then the cord connects to harness plug.

Unfortunately, Subaru has been discontinuing part #s for out GC-era Imprezas, so finding the direct fit has been difficult. I've narrowed it down to these 2 #s:

81881FA010
81881FA000

On all of the diagrams for the speed sensor, the cord shows up as reference 81885N. That reference goes to both parts. I would personally try the FA000 part first because Subaru shows this part as having many of the earlier cars fit that one (and it's a little cheaper). But I make no guarantees as to which one your car will use, just that you'll need it.

Good luck.
 

·
Registered
Subaru Impreza EJ20 MT 4x4 98/99
Joined
·
7 Posts
There is an extended cord that is supposed to connect to it. Then the cord connects to harness plug.

Unfortunately, Subaru has been discontinuing part #s for out GC-era Imprezas, so finding the direct fit has been difficult. I've narrowed it down to these 2 #s:

81881FA010
81881FA000

On all of the diagrams for the speed sensor, the cord shows up as reference 81885N. That reference goes to both parts. I would personally try the FA000 part first because Subaru shows this part as having many of the earlier cars fit that one (and it's a little cheaper). But I make no guarantees as to which one your car will use, just that you'll need it.

Good luck.
Thanks for your tips! now I have a direction to go ?
 
381 - 400 of 408 Posts
Top