Subaru Impreza GC8 & RS Forum & Community banner

181 - 200 of 393 Posts

·
Registered
1998 legacy gt 2.5 silver
Joined
·
10 Posts
ej25 to ej22

ok im wanting to put the ej22 in place of the ej25 phase 1 with a manual transmission. this ej22 im about to buy is butted to a automatic transmission. should that make even a difference? i wouldnt think so just remove the torque converter right an replace it with the clutch and pressure plate right? just let me know what you think
 

·
Registered
96 reg wrx sa wagon
Joined
·
5 Posts
Hi everyone,am new to this forum and have a few questions about the conversion from auto to manual...I am english after all....haha...You guys have some serious metal over there in the good old usa.I hadn't heard of a 2.5rs before joining this forum and am so jealous...I have a 95 registration wrx import and am currently converting it to run a manual box from a ra....My car has no tcu or cruise control or abs but does run a seperate ecu for the auto box.Am wondering if i can remove this and trace the wiring and remove this to without any problems as i want to make it look oem???....I have the same two plugs running down to the auto box as Toyolla86 has but only have a four pin plug running from the manual box...I have tried forums in the u.k for answers but keep hitting a brick wall with replies along the lines of....'sell it and buy a manual'...That would be the easy option....haha....I understand i have to use the ecu from the manual donor car as the fuelling is different....Is this true??.....great guide by the way Letze but please help!...
 

·
Registered
1995 WRX 2015 F150
Joined
·
1,873 Posts
Hi everyone,am new to this forum and have a few questions about the conversion from auto to manual...I am english after all....haha...You guys have some serious metal over there in the good old usa.I hadn't heard of a 2.5rs before joining this forum and am so jealous...I have a 95 registration wrx import and am currently converting it to run a manual box from a ra....My car has no abs or cruise control but does run a seperate ecu for the auto box.Am wondering if i can remove this and trace the wiring and remove this to without any problems as i want to make it look oem???....I have the same two plugs running down to the auto box as Toyolla86 has but only have a four pin plug running from the manual box...I have tried forums in the u.k for answers but keep hitting a brick wall with replies along the lines of....'sell it and buy a manual'...That would be the easy option....haha....I understand i have to use the ecu from the manual donor car as the fuelling is different....Is this true??.....great guide by the way Letze but please help!...
Fast and easy way to do the wiring-

You'll need diagram to look at. Search online they are out there.

Inside the car-

Remove the TCU for the auto trans near the pedals.

At the ecu, ground the at/mt id pin.

Under the hood at the two big plugs for the auto trans-

You need to jumper the nuetral switch wires so it starts.

Connect the reverse light wires to the the switch on the 5 spd.

These are both on one big plug and next to each other.
 

·
Registered
06 Impreza 2.5i
Joined
·
470 Posts
ok im wanting to put the ej22 in place of the ej25 phase 1 with a manual transmission. this ej22 im about to buy is butted to a automatic transmission. should that make even a difference? i wouldnt think so just remove the torque converter right an replace it with the clutch and pressure plate right? just let me know what you think
keep the 2.5 and the MT. Give me the 2.2. LOL.
 

·
Registered
1998 legacy gt 2.5 silver
Joined
·
10 Posts
ok i have an issue i just dropped in the 2.2 in exchange for the 2.5 and it wont start. its definatly trying and yes its getting gas and spark and air. so why no fire just pops. one thing though i do not have the exhaust hooked up yet. will that cause it not to run? i was thinkin no exhaust means no back pressure on the motor witch will cause it to just flood with gas and not fire? am i correct? my common sense is kickin in here so im just going by ear. its raining here so i havent had a chance to hook up the exhaust. i just figure it would start but these boxers are different than v or slant. so whats going on am i missing something stupid?
 

·
Registered
01Black2.5rs
Joined
·
2 Posts
ok I need some help.. What i'm wanting to do is take the motor and 5MT (possibly along with wiring harness and ECU if needed and other stuff) from an 05 2.5 rs and put it in my 01 2.5rs with AT. I dont know if this is even possible or if it is going to be way more work than finding everything from 98-01 rs. The thing is my dad owns the 05 rs and I can take anything off of it. If anyone could tell me if this is possible and what parts I would need specifically from the 05 to make it possible. I just wanna make sure it is possible. Also I really want Cruise and ABS! If I cant then I won't do it.
 

·
Registered
1997 impreza
Joined
·
65 Posts
k so will i really need a drive shaft are they different in size/or input splines... between the 4eat and 5mt trannies... i ask cause i have a 97 auto with the 4.11 and i got a 99..5mt that is also 4.11 so i dont need a rear end and was hoping that i wouldnt need a driveshaft either please let me know
 

·
Registered
opendeck251+stiInternals
Joined
·
483 Posts
You NEED the M/T driveshaft. The A/T is 3 inches or so longer than the M/T, so you need a longer driveshaft when you use the M/T.

Use this to double check your 5mt front diff ratio.

And what is this "remove the tcu" stuff. I didn't have to, and I have both cruise and ABS, so what gives...


~Josh~
 

·
Registered
opendeck251+stiInternals
Joined
·
483 Posts
^^^^^ Tranny, tranny x-member, driveshaft, shifter linkage, rear diff(maybe), pedal box, clutch master and slave cylinders, and a little searching would help as well.:cool:


~Josh~
 

·
Registered
98 2.5RS RBP
Joined
·
170 Posts
im swap my car to manual. a friend of mine gave me his pedal box out of his 06 STi. i looks like it should bolt right in but it was a little bit of a pain to get it in and when i finally got it in the 3 bolts the go in the top dont line up right (the 2 over the brake are about a 1/8" off and the one that goes over the clutch master linkage is off by a lot. i was wondering if anyone else has run into this problem and if they were able to modify something to make it fit better.
 

·
Registered
Joined
·
2 Posts
Ok, so I dont have a RS, But im In the works of putting parts together for a 2.5/5mt swap into my 99 Impreza L. My car should be a bit easier, no cruise or ABS to worry about. But one thing Ive had trouble getting a clear answer on is rear CV shafts. For my Impreza, napa list rears for auto or manual. So If I swap to the matching 5mt rear diff, do I have to replace my rear CVs?
 

·
Cluster Specialist
1999 Impreza RS - WRB
Joined
·
479 Posts
You only need to swap your rear diff if the trans you're getting won't match the your current rear diff's final drive (4.11).

Keep your CV shafts. All of them. You'd only need to change the drive shaft when you swap.
 

·
Registered
Joined
·
2 Posts
You only need to swap your rear diff if the trans you're getting won't match the your current rear diff's final drive (4.11).

Keep your CV shafts. All of them. You'd only need to change the drive shaft when you swap.
Thanks. I'm hoping to find a manual with the same gear ratios, less parts to buy. And If I dont have to buy CV's even if I change the diff, thats good.
 

·
Registered
1998 2.5RS
Joined
·
32 Posts
My check engine light is on because i have an automatic transmission error and i did a manual swap w/o the use of the manual ecu...is there a diode or something that i can use to over ride the error code
 

·
Registered
1995 WRX 2015 F150
Joined
·
1,873 Posts
My check engine light is on because i have an automatic transmission error and i did a manual swap w/o the use of the manual ecu...is there a diode or something that i can use to over ride the error code
You need ground the at/mt id pin at the ecu.
 

·
Registered
98 2.5RS RBP
Joined
·
170 Posts
i have a 98RS with an auto to manual swap. i spliced in the neutral and reverse switches and the car starts fine. my problem is that i have a high idle. i tried searching this thread but only got back one post with a high idle and there wasnt anything helpful in it. has anyone else run in to this problem or does anyone have an idea of what it might be?
 
181 - 200 of 393 Posts
Top