Subaru Impreza GC8 & RS Forum & Community banner
1 - 20 of 22 Posts

·
Registered
Red 2007 BMW Z4 M-Coupe
Joined
·
1,331 Posts
Discussion Starter · #1 · (Edited)
Its time to make room again!


  • Enkei RC-G4 Rims. Has Continental Extreme Winter Contact tires. 15x7 et 50 with tires in a 195/60R15. Perfect fitment over 4 pot brakes! Great condition! SOLD!!
    Review: http://www.rs25.com/forums/f145/134896-zerodrift-vs-1999-impreza-2-5rs-42.html#post2699012

  • RallyTek Skidplate for the GC. Good condition, but used. Taking Offers!
  • GC Stock strut tubes: These are ready to have Koni inserts installed. They are also powder coated a color similar to STi pink, but is slightly brighter. Asking $80 shipped to the lower 48!
  • Misc 8" woofer: Came from a home audio sub enclosure. Works well but is outclassed by modern name brand subs. So great for cheap projects or general tinkering. SOLD!!!
  • Pioneer DEH-7700MP (something): In great working condition. No remote included. I think this is the 7700 model but need to confirm. Picture is attached below. Taking Offers!

  • Corner Lights: These have the amber reflector removed and have been given a smoked finish on the inside of the reflector (in the non critical areas). $20 shipped.

    Shuttle bare-bones pc: Model #SN21G50-L3GH00-11 Comes with the case, ram and a CPU.
    Ram: Kingston KVR400 @ 1GB
    CPU: AMD... Gotta pull it and check model. Asking $65

    Hankook Tires: 225x45R16 Old thread: http://www.rs25.com/forums/f181/t154148-hankook-k106-tires.html Asking $55
  • Bosch OEM replacement fuel pump Only used for a few weeks as a spare while high flow pump arrived. Purchased for $170, Asking $95!
  • GC fog lights: SOLD!!
  • Amps: SOLD!

I will be adding more items to this thread along with pictures this weekend. If you have any questions please feel free to ask! :)
 

Attachments

·
Registered
Red 2007 BMW Z4 M-Coupe
Joined
·
1,331 Posts
Discussion Starter · #3 ·
Here are a few pictures:

The fog lights have the adjusting set screw assembly but it is currently not on the lights themselves.






Struts:


 

·
Registered
Red 2007 BMW Z4 M-Coupe
Joined
·
1,331 Posts
Discussion Starter · #12 ·
The Sony amp powers on and appears to be fine. I have no way to test for signal though, but there is no reason why it shouldn't be working. It was removed in good working condition and has sat for about 1 or 2 years in a box. The reason I am so conservative is because I was not the original purchaser of the amp. It came with a car and I have no real knowledge of this unit.

The Planet audio amp was purchased new and is a high quality amp that I chose due to the high quality components and how clear the amplified signal is. I have no doubt that this unit works fine and will stand behind it's quality; hence the reason why I am so willing to accept returns (if the value is worth it).
 
1 - 20 of 22 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top