Subaru Impreza GC8 & RS Forum & Community banner
1 - 7 of 7 Posts

· Registered
2000 Subaru Impreza 2.5RS BRP
Joined
·
188 Posts
Discussion Starter · #1 ·
So, about a week and a half ago I ran an fuel injector cleaner through as I usually do about every 15000 miles. As usual, the CEL came on. Usually goes off within a day or two. This time around the CEL has stayed on.

Took it up to autozone to get the code read, cause I can't exactly afford to leave it at the stealership for a couple of days(it's my DD). The guy plugged in the diagnostic machine and told me that it wasn't able to read the code.

I haven't heard, felt, smelled, or seen any difference in the running of the engine, but I know I shouldn't run with the CEL on for too long. I don't want to mess anything up too horribly bad.

Anyone have any advice or any insight as to what could be wrong or what I can do?

Please help...!
 

· Meany Head
2000 RSC
Joined
·
13,908 Posts
Thats strange. I've personally only seen that happen once before. My previous car (z24) did the same thing, the CEL light was on, but nobody could get any codes from it. Including the dealer. On top of the fact that the car would randomly stall out for no good reason, so the CEL was obviously for a reason. In the end, the ECU was bad, and had to be replaced. Hopefully that's not the issue with your ride.
 

· Registered
2000 Subaru Impreza 2.5RS BRP
Joined
·
188 Posts
Discussion Starter · #5 ·
Was thinking possibly about resetting the ecu and seeing if that would do any good. I did just switch to a different intake setup, but I doubt that would cause a CEL. Thoughts?
 

· Registered
silverthorn RS coupe
Joined
·
319 Posts
Was thinking possibly about resetting the ecu and seeing if that would do any good. I did just switch to a different intake setup, but I doubt that would cause a CEL. Thoughts?
I wouldn't just clear it and forget it. If the light has not turned itself off after a couple of drive cycles, then it is a reaccuring problem. It could be a knock sensor malfunction, front heater circuit, many different things that be a problem, but the car would still feel fine.

just go by the dealer and ask them to scan it. I am a subaru tech and scan customers cars all the time in the lane.
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top