Subaru Impreza GC8 & RS Forum & Community banner

1 - 14 of 14 Posts

·
Registered
1998 Subaru Impreza L
Joined
·
4 Posts
Discussion Starter #1
I put a new clutch on a 98 impreza L coupe i bought a month ago. After I finished putting it back togther I started it up and then it cut off. It won't stay on for longer than about 5s. I'm hoping I just didn't hook up a sensor. I'm pretty new to subaru and I need some sugguestions on how to fix it...
 

·
Registered
1999 Impreza L
Joined
·
567 Posts
CELs?

my cousin had a similar problem, car starts but stalls out a few seconds later, ended up being a crankshaft position sensor.
 

·
Registered
1998 Subaru Impreza L
Joined
·
4 Posts
Discussion Starter #8
check engine light was just a bad O2 sensor( the back one). The light has been on before I had the car. I removed the exhaust from the cat back could it affect it?
 

·
Registered
99 22B replica
Joined
·
1,322 Posts
My car did this when the MAF sensor went. It didnt give any related codes. I thought it was a fuel problem and replaced the pump, filter, and regulator before I found out it was the MAF. Deffinately get the codes scanned. Start with the cheapest fix first. Vac lines off the torque box
 

·
Baby❤Daddy
98L Wagon
Joined
·
27,848 Posts
fuel lines being backwards from the filter to the top of the intake manifold will cause this as well. did you remove them when doing the clutch job? how did you do the clutch? engine out? or tranny out?
 

·
Registered
Joined
·
92 Posts
Along with what else has been said, relays relating to the fuel are also another big one I would check. Does it do this periodically or every time you turn the key?
 

·
Registered
1998 Subaru Impreza L
Joined
·
4 Posts
Discussion Starter #14
I do apoligize. It was just a vacuum hose disconnected that was under the mass air flow sensor. I'm fixing a wheel bearing and valve cover gasket now.y
 
1 - 14 of 14 Posts
Top