Subaru Impreza GC8 & RS Forum & Community banner
1 - 18 of 18 Posts

· x
2000 BRP RS sedan
Joined
·
701 Posts
Discussion Starter · #1 ·
So I made the mistake of taking my car to Singer Subaru in Plaistow NH. I had a stripped bolthole on the block and needed it re-threaded, they did so and did a good job after breaking my starter and refusing responsibility.....

also the mechanic had disconnected the drivers side throttle wire and was not planning on reconnecting it until I asked him twice. Now that I've finally got the car fixed It starts up at WOT because there is no tension on the line.
Any help?
 

· Registered
99 Aspen White Coupe
Joined
·
480 Posts
It starts at WOT because of no tension on the throttle cable? I'm a little confused on that, since if there's no tension, the throttle should be closed. Could you clarify a litte?

And yes, they need to fix it, talk to a manager.
 

· x
2000 BRP RS sedan
Joined
·
701 Posts
Discussion Starter · #9 ·
I'm also confused.. I have no clue how this could be happening, it's sitting past the closed position yet the throttle is pinned on startup. I knew I shoulda just went to ECS.
 

· Ex-Mooderator
2001 RSTi, 2011 WRX Hatch
Joined
·
3,505 Posts
I'm also confused.. I have no clue how this could be happening, it's sitting past the closed position yet the throttle is pinned on startup. I knew I shoulda just went to ECS.
Idle control solenoid issues?

PS: I don't even think that you can start the car with the throttle at WOT... it would be too lean to start.


Plant your right foot and see if it starts...

-- Dave
 

· x
2000 BRP RS sedan
Joined
·
701 Posts
Discussion Starter · #11 ·
What happens is, I can start the car and then it immediately Revs to redline and I have to shut it down. I suspected the throttle cables, being that they were messed with last.

And why do you suggest starting the car with the gas floored?

The starter was replaced.. although I'm not sure that could be responsible.
 

· Registered
99 Aspen White Coupe
Joined
·
480 Posts
There is no way your starter can do that, just simply can't.

For some reason there is too much air flowing into the engine. I'd be very suspicious that it's not at WOT, for the reasons AcquaCow stated. Even at part throttle your engine will rev up to redline.

I'd check and make sure the throttle isn't somehow stuck open. Take off your airbox and look at the valve in the throttle body (that valve is the actual throttle. It should be fully shut. If it's not, that's the problem, find out what's stopping it from closing. If it's fully shut, there's likely something wrong with the IAC.
 

· x
2000 BRP RS sedan
Joined
·
701 Posts
Discussion Starter · #14 · (Edited)
Greaat.... now after trying to play with the pedal while starting i loaded with gas and then backfired through the intake burning the shit out of my new air filter.

And after talking to the fucking dooshbag at Singer Subaru he just insisted it was not their fault and that I can't prove it was... WTF! what kind of customer service is this? Waiting till tomorow for the manager but I'd rather fix this myself than let these morons touch my car and break something else.
 

· Premium Member
overdeveloped beater
Joined
·
9,088 Posts
Wait a minute. I've got a few questions, cuz something doesn't sound right.
One of the cables is for the cruise control. Which one did the mechanic leave off?

If he left the throttle cable off, how did you get it out of the shop?

If it started fine at the shop, what changed once you got it home or wherever the problem started to happen?

What bolt hole did they fix?

Why were they even in the area of the starter?
What happened to it to fuck it up?

What exactly did they do (according to the work order)?

Fuel injection isn't like carbs.....you can't flood it by pumping the gas during cranking. The ECU is going off a startup routine. If the TPS shows WOT, the ECU won't inject fuel during cranking. Its not possible to start at WOT. It might be 50% and sound like WOT....but it isn't wide open.
 

· x
2000 BRP RS sedan
Joined
·
701 Posts
Discussion Starter · #16 · (Edited)
Thanks for all your responses. Turns out the fkin mechanic didn't put the throttle wire back on properly and the butterfly valve on the throttle body was slightly open. I found his mistake, fixed it, and proceeded to go to Singer Subaru to bitch them out for making such a PITA over a stupid mistake they refused be co-operative with, let alone down right rude to me over.

Again thanks for all the help and sorry for not realizing it was the other cable that was misaligned.
 

· James incognito
Black 06 STi & 07 Wagon
Joined
·
381 Posts
There has to be some sort of warranty on repairs. Look at the paperwork/policies.

If they had told me "You can't prove it" I would have replied "My lawyer is going to sue the crap outta you for denying warranty on work you've done."
 

· Ex-Mooderator
2001 RSTi, 2011 WRX Hatch
Joined
·
3,505 Posts
Thanks for all your responses. Turns out the fkin mechanic didn't put the throttle wire back on properly and the butterfly valve on the throttle body was slightly open. I found his mistake, fixed it, and proceeded to go to Singer Subaru to bitch them out for making such a PITA over a stupid mistake they refused be co-operative with, let alone down right rude to me over.

Again thanks for all the help and sorry for not realizing it was the other cable that was misaligned.
Good to hear.

Sorry for making you set your air filter on fire.

-- Dave
 
1 - 18 of 18 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top