Subaru Impreza GC8 & RS Forum & Community banner
1 - 7 of 7 Posts

·
Registered
2005 Impreza 2.5RS
Joined
·
899 Posts
Discussion Starter · #1 ·
So Im having some issues here guys:

Got a CEL after filling up yesterday. Ran it: "Catalyst somethingorrather Below Threshold" ... erased it, wasnt too worried Ive always ran no cats on my cars and figured Ill just get the cats taken out soon.

Then pulled the car into a bay at work right before close. Pulled a rattling heat shield off the exhaust mani. Got in, reved it to see if the rattle was gone, then pulled it out back and parked it.

Closed up at work and got on my way home. Came up on a red light pressed the clutch and brake in to come to a stop and car died as Im rolling to a stop. Thought maybe I didnt have the clutch in all the way ans stalled it ... I cam of course new to driving 5-speed.

Next time I try to stop same deal, RPMS drop and shuts off not stalls. So then I notice that when the RPMS fall if I shift into neutral it doesn't die. Gears shift fine and everything. When Im at a stop I can hold the clutch and brake in with it in gear and no issues.

Now I am new to driving 5-speed so needless to say the clutch hasnt been on my good side lately, but please dont tell me I could have burnt out the clutch from just a couple stalls and some rough shifting?
 

·
Registered
2005 Impreza 2.5RS
Joined
·
899 Posts
Discussion Starter · #7 ·
Update:

Messed around while driving and as the RPMs would drop, I would give it a bit of gas right when it got down to idle area and then it wouldn't die. After doing this several times the problem has gone away and shes running like a top!

Thanks guys for throwing advice my way! Much appreciated. Mods can close this thread or leave it up in case anyone else is searching the same problem...
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top