Subaru Impreza GC8 & RS Forum & Community banner

1 - 11 of 11 Posts

·
Registered
95/99 Brighton STi
Joined
·
2,945 Posts
Discussion Starter #1 (Edited)
UPDATE: Feb 25th - Finally received shipment of my rods.

---------------------------------------------------------------------------------


Jan 2nd, I sent $104 for 4 STi connecting rods. He got upset with me because I offered him a lower price but yet, he accepted.

Jan 24th, I received the rods. Yes, 3 weeks later; says he is busy. I get it, many people nowadays have busy lives.

What really annoyed me was that two of the rods had mismatched caps, which render them useless. So I let him know about the situation and ask for a refund and if I can send all 4 rods back. He offers to get me two other rods with matching caps and says he'll send a pic so "I'm all happy".

Jan 27th, I send back the two rods with a tracking number

Feb 12th, I get a tracking # for the 2 rods he's sending back. Never sends the pic.

Been tracking ever since. Noticed the other day the rods were heading west.

Feb 18th, they're out for delivery in California. IM IN VERMONT!

I sent a PM saying you either sent me the wrong tracking number or you sent my rods to the wrong person. Please just give me a $50 refund.

93stiImperza, if you're reading this, please just refund me $50 and keep the two rods. That, or prove to me that rods are being shipped to me and not some random person in CA.

FYI, I have all PM's to back up my claims and dates.

---------------------------------------------

Feb 22nd, after emailing 93stiImperza, he contacted me with the correct tracking number. He accidently sent me bue car's tracking# (thanks Chris). Tracking # says it was shipped on Feb 20th :/ better late then never.
 

·
Registered
95/99 Brighton STi
Joined
·
2,945 Posts
Discussion Starter #3
I never said he was in California :confused:

The rods are being shipped to California, instead of Vermont.
 

·
Registered
Joined
·
54 Posts
I'm having problems with this user as well. He dropped off the face of the earth on the 12th, and has not gotten back to me on the forum, PayPal, or through e-mail.
I bought an exhaust from him on January 6. He lied to me initially and told me he shipped out my exhaust "days ago", then retracts his statement and says he'll ship it out by the weekend (this is all in January).

As I track the shipment, I notice it's in town, and then all of a sudden it gets shipped back to IL.
I spoke to USPS, and they said that it would only return to sender if it's an address problem, or if the seller requests it to be returned.

One of the more troubling things about this is that he didn't even insure the shipment for the package's full value. I have since requested a refund minus half the shipping and paypal fees, but he has not responded.
I have opened a paypal dispute, and it has been escalated to a claim.
 

·
Registered
95/99 Brighton STi
Joined
·
2,945 Posts
Discussion Starter #8
I noticed as well that he hasn't been on the forum much lately. I was able to get a reply from him via email.

Feb 25th - I finally received the last two rods.
 

·
I ❤ BOOBIES
01 2.5RS
Joined
·
2,115 Posts
Didn't even see this thread until now.

Just had a successful transaction with this guy. Bought a set of tail light harness's a week or so ago, nothing high dollar but was sent to me none-the-less. I kinda forgot about the buy and was sitting in my mail box for a couple days. Haven't plugged them in yet but they look to be in good working condition.
 

·
Registered
Joined
·
54 Posts
Update:

My paypal claim has been closed; I just got my refund.
He did not respond to me at all since before Valentine's Day, but he has been logging in.

I do understand he has a lot of positive feedback over the years, but it's unacceptable to disappear and neglect the buyer altogether.
I can't even leave negative feedback because it has been too long...

BUYER BEWARE!
 
1 - 11 of 11 Posts
Top