Subaru Impreza GC8 & RS Forum & Community banner

1 - 7 of 7 Posts

·
Premium Member
2002 Impreza RS 2.5
Joined
·
47 Posts
Discussion Starter #1
I test drove a '02 RS 2.5 yesterday that had only 15 miles on it. I doubled that. But it smells like burning plastic or paint inside the car. Is that just engine paint getting hot, early on?

Thanks.

Nice power--a little soft at the low end (0-20) but then it picks up. Solid feel.



blakespot
 

·
Registered
2.5 RS
Joined
·
169 Posts
You might want to look into that. I have never smelled burning plastic or paint. I have smelled boiling water but that is only cause I get up on it and rev it really high. The water hose can't take the pressure so some water squirts out. Test drive another one, and tell them why. They may say it's no big deal and it might not be but tell them you want to do it anyway. It might be wires to close to something. But then again I got my car with 85 miles on it, I didn't really care
 

·
Registered
2.5 RS
Joined
·
169 Posts
almost forgot, there is a lag when you first take off, I can't stand that but understand it will get used to your driving. When I am 1st i rev it pretty hard and it got used to it and it helped a little bit. But on hills, ohhhh man, I have it floored and it doesn't move. I will find a way to fix that and when i do I will post the fix.
 

·
Registered
Joined
·
1,133 Posts
I had a similar smell. I noticed it the first couple times I drove my car hard. I think it's stuff in the exhaust and should be normal. Wouldn't hurt to get it checked out though if it persists.
 

·
Registered
Joined
·
2,332 Posts
It is the cosmoleen(spelling), a coating that is put on the bottom of the car before shipping. Its normal. It is kind of funny when I take a new WRX on a test drive and there is smoke coming out of the hood scoop. :eek:

If the car has over 20 miles on it expect for all the junk to be burned off by then.
 

·
Premium Member
2002 Impreza RS 2.5
Joined
·
47 Posts
Discussion Starter #6
Icon25rs said:
almost forgot, there is a lag when you first take off, I can't stand that but understand it will get used to your driving. When I am 1st i rev it pretty hard and it got used to it and it helped a little bit. But on hills, ohhhh man, I have it floored and it doesn't move. I will find a way to fix that and when i do I will post the fix.
What are you talking about???


blakespot
 

·
Registered
Joined
·
1,133 Posts
Yeah. What are you talking about? Flooring the car up a hill and it not moving? This car is great at going up hills... do you have an auto/manual? :confused:
 
1 - 7 of 7 Posts
Top