Subaru Impreza GC8 & RS Forum & Community banner

1 - 20 of 26 Posts

·
Registered
Joined
·
100 Posts
Discussion Starter · #1 ·
I finally got the money to buy my Borla headers. The install, while a huge pain in the ass wasn't all that hard. I stripped a bolt that put me back and hour, but all in all it was about a three hour install. If anyone else is going to do the install themselves I recommend having a friend help you, and I found it much much easier to pull of the cats and headers together. Then bolting the new headers onto the cats and then bolting the whole assembly back on. NOTHING BETTER THAN THE SOUND OF AN OPENED UP SUBARU!! My car currently has ...... :sunny:

Borla Headers
Stromung mid pipe
Stromung dual tip muffler
Cusco rear sway
Cusco rear strut brace
Cusco front strut brace
Cobb CAI

Scott
 

·
Registered
2000 Impreza 2.5 RSTi
Joined
·
324 Posts
Thats sweet... i just installed my borla headers last weekend 11-16-02. Man aren't they sweet. The power and the sound are incredible. Im definlately glad i got them.

My car currently has:

Cobb CAI
Cobb (stromung) cat back exhaust
Borla Header
Cusco Front Strut Brace
Toyo Tires
Clear lenses
Cobb Short Shifter
STi tranny mount
Hardened bushings
yellow Star and RS badge
Yellow painted calipers
Silver Dash kit:eek:
20% tint
 

·
Registered
Joined
·
100 Posts
Discussion Starter · #3 ·
Did you get a Check Engine Light? Mine showed up about two weeks after the install!
 

·
Registered
2001 Impreza RS BRP
Joined
·
1,359 Posts
That is my next project after Christmas!!!

Yeah new toys!!! ;)
 

·
Registered
2000 Impreza 2.5 RSTi
Joined
·
324 Posts
Scotty, No check engine light yet... **fingers Crossed**


Thats strange that it turned on 2 weeks later, maybe its something else?

Anyway i reset the ecu after the install maybe that is the reason teh CEL dind't come on.
 

·
Registered
Joined
·
100 Posts
Discussion Starter · #6 ·
I am going to have the CEL checked at Autozone this weekend. It was weird, I was just driving down the road and it turned on. I reset the ECU upon install. Then again when I got the CEL. CEL went away after second reset but came back after about twenty miles of driving. I'll figure it out soon enough!! :D
 

·
Registered
2000 Impreza 2.5 RSTi
Joined
·
324 Posts
Yo scottie,... remember when i said i didn't get the CEL.. Damn i was wrong turned on bout a week after the install just outta the blue... She has to go in on friday to get a tune up anyway so imma have the suby dealership check that out.. Im sure its nothing! anyway goodluck wit your suby
 
Silver 2K RS Coupe
Joined
·
1,864 Posts
Whoa! I got a CEL tonight!

The header has been on my car for about a week now, and I got a CEL tonight when I started it in a parking lot. The engine was already warm. I turned the engine off and restarted, CEL. Again, no CEL, and it stayed off all the way home. I didn't even reset anything. Fricking wierd!
 

·
Registered
Joined
·
100 Posts
Discussion Starter · #10 ·
HAHAHA fucking Subaru... My CEL just went away mysterious the other day. Haha I had it for about two weeks, then one day I turned it on and it was just gone...been gone for about a week now. I'm pretty sure that the code the ecu throw is "cat inefficiency". Bascially from what I've heard you can't do much to fix it other than A)Take the headers off B) Wrap the hell out of the headers with header wrap. Hope yours goes away like mine!:)
 

·
Registered
Joined
·
25 Posts
I have the Brullen Header back installed on my 2001, a week after the CEL light came on, then a couple of days later off... Haven't seen it since and that was 6-7 months ago.

Hope you guys have the same luck..

Slim
 

·
Registered
2000 Impreza 2.5 RSTi
Joined
·
324 Posts
Yo, i just got my car back from the dealertoday after the tune
. The CEL read code 420 cat inneficiency. They tryed to tell me that my cat has gone bad and needs replacement and will cost 700 buckS!!! now thats some bullshit... of course i did not do it. I don't htink thereis anything wrong with it. I have heard there is not much u can do and will just have to live with seeing the CEL on the car, because it doesn't hurt anything and the car is running fine. someone correct me if i am wrong, is there anything i can do, and is having the light on hurt anything?

thanks


2000 RS coupe Silverthorn:drool:
 

·
Scoobymods Guy
2010 Legacy 3.6R Limited
Joined
·
1,157 Posts
You are right the light dosen't mean anything you can ignore it or spend 20 bucks for a fix and wire it in. Or if you don't want to do any wiring they have the whole thing but it costs a lot more:

http://www.ilpperformance.com/celfix.html

Just an FYI, I had my CEL come on not too long ago and I thought it was the 420 code too because I have a hi flow cat (no headers yet but I'm looking at these: http://www.techworkseng.com/prod03.htm I can't use the Borla style because the way they run in front of the oil pan it would hit the lines to my OEM oil cooler)


Anyway it turned out to be my Front O2 sensor, and that was screwing up my gas mileage and everything. I pulled my code and figured it out, so don't automatically assume it's the 420 I guess.
 
Silver 2K RS Coupe
Joined
·
1,864 Posts
Peaty said:
I can't use the Borla style because the way they run in front of the oil pan it would hit the lines to my OEM oil cooler)
Peaty- ARG has the Borla and the OEM oil cooler, and it clears fine, though the clearance is close. Custom aluminum heat shield or header wrap required. Just an FYI :)
 

·
Scoobymods Guy
2010 Legacy 3.6R Limited
Joined
·
1,157 Posts
ampsarus said:
Peaty- ARG has the Borla and the OEM oil cooler, and it clears fine, though the clearance is close. Custom aluminum heat shield or header wrap required. Just an FYI :)
Cool thanks for the info, good news. I talked to Borla and they couldn't tell me if it would clear or not.
 

·
Registered
Joined
·
14 Posts
Hey Peaty, did you put that CEL fix in yourself? If so was it hard? Also, I live in the KC area. I meet you a while ago at a Hooters meet in North KC. Just wondering if you might be willing to help with a Clutch maybe flywheel job for me in a few months.

Mike
 
Silver 2K RS Coupe
Joined
·
1,864 Posts
ThermoTec header wrap

Here is a pic of the Borla wrapped in ThermoTec before painting.
I got some 1500 degree paint in flat white to finish it off.
Should keep nearby assy's cool and hopefully keep the cats hot.
I'm going to have 2 bungs installed somewhere downstream; 1 for an A/F gauge and 1 for an EGT gauge.
 

Attachments

1 - 20 of 26 Posts
Top