Subaru Impreza GC8 & RS Forum & Community banner

1 - 7 of 7 Posts

·
Registered
Joined
·
613 Posts
Discussion Starter #1
Jeeeeze. my silicone 90 degree elbow on the intercooler has had a 1-1/2" crack in it for ever as close as i can figure. now it registers about 16 lbs of boost on th map sensor (sds). talk about a kick in the rear. thank you santa. thank you jesus and thank you to all the other hallucinations i can now invoke with tractor like torque. if you have ANY frequent flyer miles at all you should come take a ride. i may motor over to fame tomorrow in seattle for a test squirt or two on the chassis dyno..
 

·
Registered
Joined
·
613 Posts
Discussion Starter #2 (Edited)
update made it to fame, very nice guys. blew a 180 h and 218 lbs of torque at 3500,with a very nice flat power band that must be about 250lbs at the tires? not bad not bad.. room for improvement. time to lean it up a bit. i have had it buried in the 15 ish side of rich. on the way back i coaxed it up to 14 (or closer to stoic) across the band and it felt lots better.anyway i made it across the state of wa and back without any issues and this is a big mental hurdle for me. obtw there was a motorless cherry merc gull wing 300 in the dyno bay. what a treat.edit; i forgot to mention,xbox was at fame all last week taking soundbites for their next car game.
 

·
Registered
Joined
·
83 Posts
5252,

How many pounds of boost? If you were at 16 psi, you should have way higher numbers. Did I read your first post correct? At 12 psi and low comp engine, I am at 200 and 230 ish torque. On Vishnu Tuning dyno. Notorious for reading low numbers. Iam going to go to 16 psi and I should be up to 220 and 260 or so torque to the wheels. Plus my EBC will be working properly by that time so boost will come earlier than the last time it was on the dyno. I will find out soon. That is if nothing snaps, crack, or pops.

Paul...
 

·
Registered
Joined
·
852 Posts
I agree with Paul, those numbers seem low. Is there something you are not telling us? What were your quarter mile numbers?


Graham
 

·
Registered
Joined
·
613 Posts
Discussion Starter #5 (Edited)
that was only at ten lbs. my map sensor was erroniously reading 16, and mapping rich at the top, i changed it and it's back to what the gauge says; ten lbs. but it is a flat torque band that starts at 1500 rpms and holds flat to 3500 where it drops slightly, the map sensor should bring it back flat to 5250. but i think i may have blown a head gasket. fear my flat torque band. :happynow:
 

·
Registered
Joined
·
613 Posts
Discussion Starter #7
no times on the strip, i have a shift interlock mechanism on my dogbox that doesn't allow for quick 2nd to 3rd or 4th to 5th. but it's getting looser....maybe this summer.
 
1 - 7 of 7 Posts
Top