Subaru Impreza GC8 & RS Forum & Community banner
1 - 3 of 3 Posts

·
Registered
2000 Impreza RS
Joined
·
60 Posts
Discussion Starter · #1 ·
Hi guys,

So I bought my car with a bit of strange issue, it seems like the driver's side turn signal/fog light/corner lamp were wired incorrectly by the PO. What used to happen is that when I hit the turn signal switch to turn left the fog light would blink and the turn signal would stay illuminated.

Recently the blinking started happening more rapidly and it appears the side marker and taillights are working but I now have no front turn signal or fog light.

It was an issue I've been meaning to address but since I rarely use the fogs it was on the back burner. I'm no electrical guru so any advice would be greatly appreciated!
 

·
Registered
2015 WRX+TE37ta
Joined
·
4,819 Posts
the plugs to the fog and turn signal are similar as well as being similar length.

Whats the PO? Either way, swap the plugs. Plug the plug that is currently in the fog into the turn signal and vice versa.
 

·
Registered
2000 Impreza RS
Joined
·
60 Posts
Discussion Starter · #3 ·
the plugs to the fog and turn signal are similar as well as being similar length.

Whats the PO? Either way, swap the plugs. Plug the plug that is currently in the fog into the turn signal and vice versa.
I'll start with that thanks!

PO = previous owner ---> My bad
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top