Subaru Impreza GC8 & RS Forum & Community banner
1 - 8 of 8 Posts

·
Registered
stm99,flatblack99,07sti,blk98
Joined
·
566 Posts
Discussion Starter · #1 ·
ok story goes like this if you can diagnose this.

replaced front 99rs hubs with 05 wrx.
installed rotora big brake kit(for 05wrx).
connected abs sensors to the car.
bleed and checked lines for leaks/filled.

took it for a test. pedal was stiff as my sti...
took it down the road. steped on the brakes ABS light goes on and brake light(in the cluster)

now the wrx abs sensor pluged staight up to the harness of the car. there should be absolutly no difference it being a wrx hub with wrx abs sensor. also shouldnt have anything to do with the big brake setup bc the abs only senses when the hub actually locks. every time i barely touch the brake pedal i get the anti-lock pumping feeling. and wont stop.(abs kicking in)


possibly failures:

wrx hubs not installed on rear=fail
front wrx abs sensors jacked up=fail
combination of both=fail

possible solutions:
replace front abs sesnors with either new wrx or rs?
replace rear hubs with wrx(will do tomarow)

any comments from people who installed wrx hubs and or big brake kit?
 

·
Registered
MY05 2.5RS blek wagon!
Joined
·
417 Posts
I think the ABS sensor type changed from external to internal or something like that between those years.

The BBK for the 05 would've bolted straight up to your RS front hubs - no reason to change them unless you had a rooted bearing or something.
 

·
Registered
stm99,flatblack99,07sti,blk98
Joined
·
566 Posts
Discussion Starter · #3 ·
i swapped the hubs and the brakes.im using 05wrx front hubs with rotora bbk on it for an05 wrx

im using the wrx abs sensors bc they were on there..should i change it to rs?
 

·
Registered
RBP 1998 2.5RS sold
Joined
·
1,036 Posts
I think the older hubs use an abs tone rings on the hubs which snaps very easily if doing a brake upgrade. I believe the wrx's use sensors on the axle. Hope that helps.
 

·
Premium Member
98 OBS, Black/Grey
Joined
·
2,724 Posts
I think the older hubs use an abs tone rings on the hubs which snaps very easily if doing a brake upgrade. I believe the wrx's use sensors on the axle. Hope that helps.

+1

just use the RS hubs.
 

·
Registered
stm99,flatblack99,07sti,blk98
Joined
·
566 Posts
Discussion Starter · #6 ·
only reason im going to wrx hubs is bc i have a full wrx drivetrain..transmission diff axles etc.eventually putting ppg gearset and a sti motor.
 

·
Registered
RS, GF, SSx2, STI GDB
Joined
·
692 Posts
If the computer is stil a 99 ABS computer, then you will need to re-use the 99 ABS sensors.I understand going to the other hubs, but the ABS stuff changed quite often.
 

·
Registered
stm99,flatblack99,07sti,blk98
Joined
·
566 Posts
Discussion Starter · #8 ·
hmm true but the abs ring on the drivetrain i got is on the axle not the hub..so there is a difference between the actual abs working and not. thats like someone putting a rs sensor on a sti and wondering why the abs doesnt read right. ill change the abs sensors and the whole drivetrain and i will see.
 
1 - 8 of 8 Posts
Top