Subaru Impreza GC8 & RS Forum & Community banner

1 - 13 of 13 Posts

·
Registered
Joined
·
32 Posts
Discussion Starter #1
Here is what appears to be happening.

Under hard driving (not *that* hard, IMHO) I get a goodly amount of ATF fluid shooting out of somewhere and getting onto the headers and heat shields to the front passenger side of the ATF pan.

I took it into the shop that I usually go to, and they said they could find no major leaks but there was a bit of seepage in the rear of the pan. They also told me that they had never taken the pan apart - and to my best knowledge nobody else has either.

They said it looked like the fluid was coming out of overflow vents above/front of the pan. The guy told me he his dragster does it quite often too; when the RPMs and load get high the fluid heats up and can overflow if there is too much in there.

I've check the tranny dipstick and can't make heads or tails of the damn thing. It could be overfilled, but the level looked OK (the highest dot wasn't covered with fluid, but the others were).

Still though, it shouldn't be leaking from ANYWHERE assuming the proper amount of fluid is in there, correct?

I'm going to go get a flush and fill done with B&M trickshift ATF fluid at Jiffy Lube sometime this week. Is this advisable?
 

·
Retired Admin
Two Mini Coopers!
Joined
·
10,637 Posts
If you're still under warranty (?) just take it to the dealer. However, when I raced my car in SCCA events and otherwize brutalize my car I've had zero leaking problems. And let me tell you, I am NOT nice to my cars. See my video of Scoobnuts? I practiced for five minutes before starting to take pictures. I'd say my tranny would not like me much after that... :lol:

I've got 30k miles on my MY00 RS if that helps to compare.
 

·
Registered
Joined
·
121 Posts
I run my auto fairly hard too,autocrosses etc,neve had that prob and ive raced on some damn hot days.Like James said id try the dealer not jiffy lube.MY00 with 17000 mi.
Good luck
 

·
Registered
Joined
·
32 Posts
Discussion Starter #4 (Edited)
Yeah, I have driven this car very hard and never had this problem before.

I tried for about 20 minutes one time to mimick your scoobnuts, but I was offroad in sand and the tires couldn't get enough grip to sling the car around, even in 1st gear.

Done quite a bit of offroading and manual shifting, never had this problem.

In fact, I only started having this problem after adding fluid to bring it up to the full line.

I bet I just screwed up and put too much in, now it is leaking out.

So hopefully a flush & fill will put the right amount in. And if not... I have somebody to blame.

EDIT-

The nearest dealer is an incovenient drive away, and they are scumbags. I have never had them fix anything properly and they always give me shit, despite me being my usual charming self.
I will only go to them as a very last resort.
 

·
Registered
2001 STM Sedan
Joined
·
455 Posts
sounds like you overheated the fluid to the point it expanded and popped the check valve...not positive though.
 

·
Registered
Joined
·
32 Posts
Discussion Starter #6
So that would make sense then.

Too much fluid, driving hard, fluid heats up, pops check valve.

So, can I un-pop the check valve? :D
 

·
Registered
05 LGT limited
Joined
·
405 Posts
Don't let jiffy lube touch your trans unless you want to buy a rebuild!!!!!!

Thoses guys suck! On the other hand, they generate a lot of business for real mechanics like myself. As far as B&M fluid, it's just overpriced, not any better than regular ATF. Just flushing the fluid without changing the filter and/or cleaning out the screen is not a very good idea. It stirs up all the crap and worn clutch facing, and it has nowhere to go except into your allready used and partially restricted filter. It's better to just drop the pan, replace the filter (if Sube's have a replaceable filter) or clean the screen and reseal it up. Then just refill with quality fluid.
 

·
Registered
Joined
·
32 Posts
Discussion Starter #8
I don't really want to go to Jiffy Lube, but I haven't been able to find any shop around that has the machine needed for a full flush of the system. Every Jiffy Lube is *supposed* to have one.

I know what they need to do to flush it and I intend to sit there and watch everything they do. The only problem I have is that I doubt there is any place I can find a transmission filter.

I can't even buy oil filters locally w/out the place ordering them.

I guess I could drive to the subaru dealer and buy a filter from them, but I'm even more hesitant to let them touch the car than jiffy lube. Yes, I know it sounds weird... but you haven't been to this dealer. I'm also worried about them bitching about my modifications like they usually do. Hell, they threatened to void my warranty for adding aftermarket driving lights if you can believe that. (I told them where they could stick their warranty and that if they ever tried I would eat them alive in court).

I suppose since I am going to have to drive out there to get the filter anyway I might see if they have the capability to flush & fill.

I would go synthetic but I already have some slow seeping (less than a quart lost in 4k miles) and I'm afraid synthetic would increase the seepage.

I'm a scooby specialist on that other board, and have been researching this transmission crap for awhile. I just didn't have any money to get stuff done until today.
 

·
Registered
Joined
·
32 Posts
Discussion Starter #9
I couldn't find any place within 50 miles that had a machine to perform the flush and fill.

So I just pulled the drainplug and got about 8 quarts out of the system.

Then I put in 5 quarts of BPM trickshift and drove around like a maniac for awhile. There was still quite a bit of smoke, but it went away after awhile. I then checked the dipstick level and added in another quart bringing the total added up to 6 quarts.

The dipstick is rather funky. Sometimes it does not read at all, sometimes it reads correctly.

Put my skid plate back on and drove around on some gravel roads like a maniac, nearing redline before manually shifting.

No smoke! I am pretty sure there is still some seepage though.

Also, that tranny filter was a pain to get off. Had to punch a screwdriver through it. All sorts of gook was inside it along with some metal particles. I stuck a big hard drive magnet on it and drove around for about 10 miles before putting the new one on. Kind of scary considering that filter had only been on there about 15k miles.
 

·
Premium Member
2000 BRP GM6
Joined
·
813 Posts
You know, that's strange. There's a thread on another forum I frequent that had a four year bump today, too. I think it's building to an epidemic!
 
1 - 13 of 13 Posts
Top