Subaru Impreza GC8 & RS Forum & Community banner

41 - 60 of 84 Posts

·
Registered
1997 impreza brighton coupe
Joined
·
170 Posts
Discussion Starter #41
cchang I did not have to modify the dash beam itself. once you mount it up there will be a gap where the two lower support legs met the transmission tunnel, this area needs a lot of attention because the srs control unit mounts to the same bracket as the lower dash beam supports. this bracket is spot welded to the transmission tunnel. I have not yet addressed this whole dilemma...still thinking about gc822bdreamers suggestion of making an adapter bracket. I want to do it but I dont know if I should snag the bracket off my RS or just machine one at work. more to come on this topic. if anybody can tell me how important it is that the srs unit be mounted EXACTLY where it was or can it be a few mm up down left or right? if I make the bracket its going to be about 10mm higher than before. due to the hardware needed to mount it.
 

·
Registered
99 Impreza RSTI
Joined
·
436 Posts
Wow man, I am impressed. You took on the work that others would have been unwilling to do, with body panels and other sheet metal work.
 

·
Registered
2000 Impreza RS BRP
Joined
·
35 Posts
ok, I'll wait on what you do. I'm just doing research for now and want to see what would be the easiest route.
 

·
Registered
1997 impreza brighton coupe
Joined
·
170 Posts
Discussion Starter #44
just went over 2000 views thanks for the interest everybody hope you're enjoying the show. Right now things are at a stand still because im trying to sell my DD 1995 bmw 525i auto. I need monies to buy some sti awesomeness.
 

·
Registered
1997 impreza brighton coupe
Joined
·
170 Posts
Discussion Starter #45
got this rack a while back, was told its an 04 sti..can anybody help me with this one. it seemed significantly wider than my original, i plan to put some moog j spec inner tie rods
got it mocked up in the car right now. magically the hoses fit(hoses came of the blue car i got (first and only benefit of buying an already swapped car)

 

·
Registered
1997 impreza brighton coupe
Joined
·
170 Posts
Discussion Starter #46
so I have been looking and thinking and measuring an trying to come up with a way to mount the srs controller for the rs and its looking like im going to cut/weld the factory bracket in. There is just no good quick way out:-/
 

·
Registered
1997 impreza brighton coupe
Joined
·
170 Posts
Discussion Starter #47
Today was a good day. I picked up a 2006 STI turbo back exhaust...$200...1000 miles on it. my hand came out the tip clean. thought it was kinda pricy bit its mint condition and came with the turbo heat shield.




 

·
Registered
1997 impreza brighton coupe
Joined
·
170 Posts
Discussion Starter #48 (Edited)
so I put the exhaust on and got a new o2 sensor for it, but I notice some bad things...
1. EGT sensor wires cut off not connected.
2. Boost control solenoid not existant, line running from turbo to wastegate T'd off to intake.
3. bypass valve on intercooler blanked off completely. could not see it when bolted up but had some foil **** blocking it off.
4. RRFPR on the fuel line by the pump. RRFPR on the fuel line between the intake and fuel filter.

This is how I got the engine and it ran fairly well without all this. Steady idle quick throttle response. although I never drove it it felt great.

Now that I have added the exhaust and o2 and got her up to temp its running like dookie. I let it idle for 5min and reved to 5k briefly but its really slow and hesitant.

Tried calling the dealer to see if they can reset my ecu only..then follow up by correcting all the hardware changes. so far I have removed the foil stuff and have vac lines to re-do the BCS system. just waiting for egt and a solenoid.
...facepalm for no knowing enough about the wrx ecu.
 

·
Registered
1997 impreza brighton coupe
Joined
·
170 Posts
Discussion Starter #49
So after much deliberation and many sketches i ended up mounting the srs unit.
No brackets. slightly modified srs unit.

First i unbolted the lower dash beam supports,placed blots throught the upper holes facing backwards



spaced the bottom out with a big old 10mm spacer




The srs unit has two screws on the bottom. remove these and you can modify the base plate that it mounts on.

I cut two 8mm wide x 20mmlong diagona slots they start about 5mm above the original mounting holes
then used the existing m6 holes for the rear mount




placed two nuts over the bolts and snugged down.



sketchy maybe...but whatever im brave.

i need to seal up the steering colunm at the fire wall,mount the steering bag, mount the front srs sensors, plug it all in and my interior
is done.
 

·
Registered
1997 impreza brighton coupe
Joined
·
170 Posts
Discussion Starter #51
Thanks gc8.
So after installing the exhaust things went bad. i purchased a rear o2(bosch exact fit) as the swap never had one and it started running really rough and threw a p0031 code(04wrx). this is for the front o2. No biggie got a bosch front o2 also exact fit
still have a p0031. replaced it for the correct denso. still have a p0031
tried unplugging the rear o2 makes no difference
i have checked all my wiring and im getting the correct voltage and grounds at the sensor and ecu. beginning to think the ecu may have an issue.
 

·
Registered
1997 impreza brighton coupe
Joined
·
170 Posts
Discussion Starter #53
yes i have read that the bosch dont do well. so i put a denso in. and i still have a p0031...
 

·
Registered
Joined
·
105 Posts
Any type of fuel additives or fuel cleaner that u might have in the tank? Try a shot of Sunoco highest gradek sometimes that might hit the spot.
 

·
Registered
1997 impreza brighton coupe
Joined
·
170 Posts
Discussion Starter #55
hmmm was thinking about that. the tank was completely dry for a year when i first installed the swap. the few gallons i added may have picked up gunk left over or just gone bad.Going to add 5 gal of premium and cycle the fp a bit. from africa so any gas is good gas to me.lol thanks for the tip.

Im doing a little logging right now and the af is pinned to 14.7 and there appears to be 0A for current so im really leaning toward wiring if the gas doesnt solve the prob
 

·
Registered
1997 impreza brighton coupe
Joined
·
170 Posts
Discussion Starter #56
car drives ok tho...fast enough to slip the tiny 1.8 clutch.
put fresh gas in-no dice
tried reflash-nope
getting 14v at idle on pin 4&5 plug b84
pulled the harness apart to have another look at the wiring and so far everything looks good. o2's have power and everything....stumped
 

·
Registered
1997 impreza brighton coupe
Joined
·
170 Posts
Discussion Starter #58
ok so turns out this had nothing to do with the o2 or the o2 wiring at all.
As i had mentioned before that portion of my wrx harness was uncut/unmodified.
I read this thread:
oxygen sensor problem - Page 2 - 1990 to Present Legacy, Impreza, Outback, Forester, Baja, WRX&WrxSTI, SVX - Ultimate Subaru Message Board

And decided to check the ecu sensor grounds. this happens at ecu pin a7,a15,c1.
No ground on a7 or a15(black red)
no wire at pin c1
I ran my fuel level ground directly to these to a7/a15. its ecu ground, so i thought the ecu grounds the fuel level sensor when the key is on.
Turns out the ecu needs a ground here...always
Pin c1 is the mt/at identifier pin for the 04wrx.

Ran a make shift ground to all these and bam no more cel!!!!!
 

·
Registered
1997 impreza brighton coupe
Joined
·
170 Posts
Discussion Starter #59
Since my last post I have about 2000 miles on the car and the clutch is done.
I dont want to replace the clutch on my 212000mile old transmission so id like to upgrade to something that might hold the power a little better. I have a 2003wrx tranny but the tail housing bearings are toast.
So ive been researching what its going to take to get that converted to 4.11.
Why 4.11? because i have a 4.11 rear diff that is lsd and my 3.9 one is old.
 

·
Registered
1997 impreza brighton coupe
Joined
·
170 Posts
Discussion Starter #60

So rode my bike to work came home to find my wonderful girlfriend had washed my car for me, seriously the best girl ever!
 
41 - 60 of 84 Posts
Top