Subaru Impreza GC8 & RS Forum & Community banner

241 - 260 of 501 Posts

·
Registered
99' WRB GC8 WRX - TooLazy
Joined
·
1,375 Posts
Discussion Starter #242
Adventures for sure. A guy in town allowed me to borrow a spark plug cable from his Legacy. Car ran fine, I reversed the snorkel intake to try and keep the snow out. I drive around a bit and then head back home. Couldn't see shit for the most part, and halfway home car started running like shit again and would barely make any power. I thought the spark cables were unhooked or some and stopped to check, they seemed fine, checked air filter, seemed fine. Drove about 20km back home like that. Got stuck once, when looking at a stationary car for a second and hit a snowdrift at a low speed while looking off the road. Said car pulled me out and I managed to get home. The road around the shop and barn had some serious snow, surprised the pos pulled through while barely running... Turns out the snorkel got clogged on the way, but the filter wasn't when I pulled over. Seems like snorkel is a no no for winter

Good times!





Sent from my SM-G935F using Tapatalk
 

·
Registered
99' WRB GC8 WRX - TooLazy
Joined
·
1,375 Posts
Discussion Starter #245
I feel like when you press print to many times cause nothing is happening and then when it finally prints you get 30 copies. I've been asking for snow for ever and now everything is going under

Yesterday around 12:00




This morning at about 9:00



Sent from my SM-G935F using Tapatalk
 

·
Registered
99' WRB GC8 WRX - TooLazy
Joined
·
1,375 Posts
Discussion Starter #248 (Edited)
We're doing good. Installed frogszkin in the snorkel intake and so far I haven't had an issue, its still getting stuffed as you can see, but the car still runs alright. Weather has gotten alot better but its still snowing. Temp has come up above 0 so the snow is super slippery, got stuck backing into that unplowed parking space earlier. I kinda knew I would but still got a little more stuck than I intended, lol. Pic is after I shoveled the space and got the car unstuck.

Also, the fogs are growing on me


Sent from my SM-G935F using Tapatalk
 

·
Registered
99' WRB GC8 WRX - TooLazy
Joined
·
1,375 Posts
Discussion Starter #250
Same. I need to wire them to a switch and be able to switch between using them with high beams vs low beams. Haven't been able to use them to much with all that snowfall since they're direct connected to the highs now

Sent from my SM-G935F using Tapatalk
 

·
Registered
99' WRB GC8 WRX - TooLazy
Joined
·
1,375 Posts
Discussion Starter #252
I used the fog wiring for mine, utilizing the for light switch.

They were not connected to my headlights at all.
I have yet to do that, connecting to the headlights was the quickest way and I am impatient, lol. Also, if you have (additional non oem) fog lights here they are only allowed to work with the high beams, otherwise they'll fail you in the inspection iirc. Not that I'm not gonna be connecting them so they'll work with low beams or park lights too

Sent from my SM-G935F using Tapatalk
 

·
Registered
99' WRB GC8 WRX - TooLazy
Joined
·
1,375 Posts
Discussion Starter #253
Everyone has seen a version of one of these trailers before, but as I saw this pic I remembered I have two wagon bodies being parted out...


Sent from my SM-G935F using Tapatalk
 

·
Registered
99' WRB GC8 WRX - TooLazy
Joined
·
1,375 Posts
Discussion Starter #260
Seems like I need to get to the drawing board...


In other news, weather has come down alot and today was really pretty at times!












Also, I tried going out to the field at home, thinking going slow was a good idea, just to see how the snow was. It was not a good idea. Tires aren't wide enough to get any proper "float", I got styck almost immediatly. So speed really is key for me to get anywhere in serious snow. I also plowed through a snow bank/drift with an open window, now only three of my fogs work (bulb is ok, prolly fucked a wire or something)









Sent from my SM-G935F using Tapatalk
 
241 - 260 of 501 Posts
Top