Subaru Impreza GC8 & RS Forum & Community banner

61 - 80 of 453 Posts

·
Registered
Y2K GM6 & 65 'Stang Fastback
Joined
·
816 Posts
I don't see a problem with the old one?!?!:screwy:

Just J/K good luck with the cooling!:naughty:
 

·
Registered
1998, RS, Rally Blue 2.0 EJ20K
Joined
·
372 Posts
Discussion Starter #63
I had to cap that lower nipple as it was hitting the frame. Now to just mount it and fill her up. I will actually get to hear my car for more than 10secs!
 

·
Registered
1998, RS, Rally Blue 2.0 EJ20K
Joined
·
372 Posts
Discussion Starter #64
Well got my radiator in and all the lines ran. Filled the radiator full then filled the resevoir till it was full. Filled the overflow tank halfway. I ran the car till warm and the temp kept rising towards the dreaded H. Bad thermostat? Air bubble in the system? I'm not sure right now. THe fluids don't seem to be moving.
 

·
Registered
1998, RS, Rally Blue 2.0 EJ20K
Joined
·
372 Posts
Discussion Starter #65
so checking on my gauges .. I went outside and it is -8 out and the temp gauge is showing it at the halfway point.


Any ideas?
 

·
Registered
1998, RS, Rally Blue 2.0 EJ20K
Joined
·
372 Posts
Discussion Starter #66
Sorry for the random posting but i'm troubleshooting out there in the cold.
My gauge cluster is acting weird. I can tap it and it will bounce around .. I think the cluster is bad. No check engine lights after 30+ minutes of idle and the engine sounds fine. Now onto the throttle cable issue as seen here









I'm thinking some 2 inch aluminium barstock cut 6 inches long and 2 inch bends on each side.

┌┘ will look something like that
 

·
Registered
2001 D2 A8L
Joined
·
928 Posts
Did you get your system fully burped? I always pour coolant into the motor via the upper radiator hose (it takes about a gallon). Then fill the radiator and reservoir. Then run it with the cap off of the reservoir. Squeeze the upper rad hose to get air bubbles out and add coolant til full.
 

·
Registered
1998, RS, Rally Blue 2.0 EJ20K
Joined
·
372 Posts
Discussion Starter #71
Did you get your system fully burped? I always pour coolant into the motor via the upper radiator hose (it takes about a gallon). Then fill the radiator and reservoir. Then run it with the cap off of the reservoir. Squeeze the upper rad hose to get air bubbles out and add coolant til full.
Oh yeah she is fully burped. I'm having an issue with my temp gauge though. Shows halfway on a cold wisconsin morning. I believe that is reporting wrong. I let the engine run for a good 30mins no check engine lights and everything was fine.

I just need to bleed my clutch now. We tried for a good 30mins and it just didn't feel right. A friend is bringing a power bleeder this week and we are going to try again.

Once the clutch is bled properly I can drive the vehicle. There are a few things I need to work out like the interior and a filter for my intake but nothing major anymore. Super excited to see what this ej20k can do.
 

·
Registered
1998, RS, Rally Blue 2.0 EJ20K
Joined
·
372 Posts
Discussion Starter #73
Hmm just got a boost gauge hooked up. Only hitting 10psi right now. Think I need a new boost controller? or is that typical for a ej20k stock
 

·
Registered
1998, RS, Rally Blue 2.0 EJ20K
Joined
·
372 Posts
Discussion Starter #74
Ok guys only hitting 10psi of boost .. do I have this hooked up right - as mentioned in another thread. I don't see a boost pill in one of the hoses.







un edited so you can zoom in and see things with out lines in the way
 

·
Registered
93', Impreza L, WRB
Joined
·
23 Posts
Nice write up man. Definitely appreciate it since i will be doing the ej20k swap soon. Unlike you, not so brave to be doing this outside with this weather plus also my daily driver so need to source a harness for 93 impreza L since i cant afford the down time for the merge.
 
61 - 80 of 453 Posts
Top