Subaru Impreza GC8 & RS Forum & Community banner

1 - 5 of 5 Posts

·
Registered
2004 Forester XTi
Joined
·
1,005 Posts
Discussion Starter · #1 ·
I just installed my full set of Eibach springs on my 2000 Impreza RS. I torqued each strut with the strut bolt @ 40lb/ft, the 3 nuts hand tight, and the arms on the bottom of the strut very hand tight (used breaker bar).
I placed the bottom-most part of the spring onto the crease of the strut and stacked everything else on top (w/ the plate lined up with the hole on the foam dampener). I've noticed that my rear left strut is dead and the rear right plate cannot be rotated (topmost triangular part of strut w/ the 3 screws on it). When I dropped the car down from the jack, the springs made sounds. I drove the car and heard so much klunking from turning and going over bumps that I feel sorry for installing the springs. By the way, the car is noticably lower. There is now little finger gap on my 50 series tires.

Was there I did something wrong?
Can you guys give me suggestions on properly aligning the strut/springs together so I won't get the klunking?
Is the suspension supposed to do this on break in w/ stock struts?
I may have to take it to the dealership to take a look at it, but that's my last wish. Thanks for any help. :(
 

·
Registered
2004 Forester XTi
Joined
·
1,005 Posts
Discussion Starter · #4 ·
Thanks, Peaty! I took off my front two struts and readjusted the hat. I found out why I was getting the clunking noise... I had the hat on the wrong way, and the springs weren't positioned to rotate with the top mount. Yay, I love the car! The firmness of the ride is hardly noticable. Next step... Struts!
 
1 - 5 of 5 Posts
Top