Subaru Impreza GC8 & RS Forum & Community banner

1061 - 1080 of 1112 Posts

·
Registered
99 22B replica
Joined
·
1,323 Posts
Discussion Starter #1,062
More coming soon. I’m just heading back to work today. Got the injectors with me. The last piece of the puzzle
 

·
Registered
99 22B replica
Joined
·
1,323 Posts
Discussion Starter #1,063
making an airdam between the rad support and bumper skin with re-purposed aircraft aluminum


First I mounted some Aluminum L brackets across the lower rad support




Then measured the gap and bent up a rectangular section to fill the gap across the bottom lip.




Then drilled some holes in both and secured with plastic clips so they are easy to remove.



Then made some side pieces with more leftover aluminum. Painted everything black and skinned the lower section with fake CF.
 

·
Registered
99 22B replica
Joined
·
1,323 Posts
Discussion Starter #1,064
Interior is back in! Man it takes all day to do something like this properly, finding all the bolt holes again through this thick carpet is a Pain.




I wanna find a way to mount a Fire extinguisher under the Passenger seat


 

·
Registered
Turbo, LS swapped Impreza RS
Joined
·
5,174 Posts
A little late to the party but if you ever do another setoff TGV deletes I would highly recommend a set of carbide burrs. They would have chewed through the divider in no time flat.
 

·
Registered
99 22B replica
Joined
·
1,323 Posts
Discussion Starter #1,068
Its Run-ning!
Running good too,

However there is a steering issue I'm working on. Its really squirley at speed even after a Professional alignment. I tried some Toe in this evening didn't help. I'm thinking it could be the steering column there is some play that wasnt there before, but not sure yet. everything else is tight




You are the man B. Thank you Sir!!
Just for that heres some more pics






 

·
Registered
99 22B replica
Joined
·
1,323 Posts
Discussion Starter #1,072
Everything is pretty much done on the car. I’ve gotta figure out what is making the steering feel so funny. There is about a 1/2” of play in the wheel that wasn’t there before, it feels mechanical in nature like maybe the linkage is loose but I tightened it down good. Aside from that it’s running good, makes a little smoke on some starts, that’s new. The rings were gapped a little loose for the extra power I was anticipating and it’s deffinately got a ton more up top. It used to flatten right off at the top above 5000 but it just pulls hard until I shift. The 3” exhaust was worth all the work for sure! Even the AC is back in action really well after adding two cans of butane coolant into the system. Feels really good to be driving it again. Road trip home in a week so hopefully nothing else comes up.
 

·
Registered
99 22B replica
Joined
·
1,323 Posts
Discussion Starter #1,073
Found the reason for the play in the steering wheel was a loose connection at the column end of the Ujoint connector. Tightened that up and the play is gone BUT the car still feels really loose on deceleration. I got as brave as 160K last night and on Deceleration the car feels like someone else is driving, it’s really freaky. I’be put over 300kms on the new setup and I think it’s safe to drive home but I really wanna get this sorted out. Deffinately more important than a tune and Dyno for more power. I’m wondering about the wheel bearings which I did for the first time... they aren’t making noise and they feel tight when it’s jacked up but could that explain the feel of the car?

 

·
Registered
2001 SRP RS Coupe, 05 FXT
Joined
·
410 Posts
I don't really have a good answer for you, but you obviously don't want to risk anything involved with the steering or brakes.. Damn good looking booty though.
 

·
Registered
98 impreza outback
Joined
·
12 Posts
rear shocks unloading on decel causing the front end to come up maybe? nice build would love to see what your other cars look like
 

·
Registered
2001 D2 A8L
Joined
·
929 Posts
Sounds like an alignment issue or worn out steering components.... Good luck figuring it out. All of my Subarus have felt very stable and confidence inspiring under normal driving conditions.
 

·
Registered
99 22B replica
Joined
·
1,323 Posts
Discussion Starter #1,077
Took the car home 1000 miles up and over the Rockies North to south a couple days ago. Runs awesome, still drives weird but I’ll be working on that ASAP. I got hit by a big rock less than halfway home and it destroyed the drivers side headlight, luckily that was the only one I got. BC highways are beautiful but Alberta highways are truck smashed, heaved, and broken garbage that no nice car should be driven on.

I installed the cruise control but I couldn’t get it to work for the drive home. I think it’s down to the steering wheel sub-switch loose wire with the female connector.

The shrouding I made works good. It’s a tighter fit than the previous shroud over the old IC. The intercooler and intake manifold were always nice a cool when I pulled over for gas.




An Auzzie guy stopped me in Jasper to ask about the car and take a pic, that helped me get over the smashed light.




I’m starting to think the loose feel of the car is because of the wheel bearing job I did (I thought I did a great job but it was a first attempt) I’m gonna have it checked out at a shop.

Also does anyone know which sway bar end links work with the aluminum control arms?
 

·
Registered
98 Wagon L
Joined
·
230 Posts
Just wanted to stop in and say I've been watching this car for years and I was hesitant about the changeover to blue but my goodness that is one beautiful 22B Clone.
 

·
Registered
99 22B replica
Joined
·
1,323 Posts
Discussion Starter #1,079
I don't really have a good answer for you, but you obviously don't want to risk anything involved with the steering or brakes.. Damn good looking booty though.
rear shocks unloading on decel causing the front end to come up maybe? nice build would love to see what your other cars look like
Sounds like an alignment issue or worn out steering components.... Good luck figuring it out. All of my Subarus have felt very stable and confidence inspiring under normal driving conditions.
I took my buddy who is a licensed mechanic out for a rip today and he had it nailed down in 5 minutes. The rear right lateral link bolt or bushing is loose. The whole hub is moving ?. Ya think they would have caught that on my first alignment. So it’s parked now until that’s fixed, I still need some front sway bar links. Are the ones with ball and sockets the ones that work with the aluminum arms?
 

·
Registered
99 22B replica
Joined
·
1,323 Posts
Discussion Starter #1,080
Has anyone installed a brake bias adjuster on a suby? I’ve come to the realization that my rears ar doing most of the work.
 
1061 - 1080 of 1112 Posts
Top