Subaru Impreza GC8 & RS Forum & Community banner

1 - 5 of 5 Posts

·
Registered
99 2.5 rs
Joined
·
6 Posts
Discussion Starter #1
so i picked up a 99 2.5rs last week, the guy told me he put new pluggs, coil, fuel pump and fuel filter on it, and a aic sensor, he said it wasnt starting! so two days later i drive it up snowboard( ripped a few doughnuts and drove up the pass in rally mode) park it and try to start it to warm my gloves! wouldnt start, come back 2 hrs later wouldnt start! go to pop start it and it fire on the last try befor pop starting it! drive it to a buddys to go over it everything seems fine! found a lose air intake tighten that think it fixxed!later that night it wouldnt start, wouldnt pop start, finally a friend tapps the new aic sensor while turning over and it fires! for the next few days it would not start like once a day and i would have some one tap it and it would fire! now it wont start at all! i pulled the aic it has no real carbon on it! so i pulled it out and the piston moves in and out when u turn the igition on and off! im so comfused! any ideas, the car it turning over great and has fuel to the engine!
 

·
Registered
Black 2001 RS
Joined
·
787 Posts
Welcome to the forums.
Try to proofread your posts before submitting, spelling does matter when trying to communicate problems through text.
Also, use paragraphs. That makes it easier for us to decipher what you're trying to say.
Your overuse of exclamation points makes me sad. Nobody can be that excited.

That said, did the PO show any paperwork for the allegedly replaced items? Or did you simply take their word for it?

What is an aic sensor? Do you mean "air intake control"? As in the plunger right above the throttle? We call it an IACV (intake air control valve), as it's not a sensor.

When this engine fails to start, what are the symptoms? Does the starter engage every time? You say that one time pop-starting it didn't work, that leads me to believe the starter is ok, but we need your input.

The fact that the engine would start randomly even before you started tapping the iacv tells me that it might not be the culprit, maybe more of a red herring. You're going to have to unplug/inspect & clean/replug every electrical connection on the engine to rule out that possibility. After that, try cleaning the cam and crank sensors.

You say it has fuel to the engine, how did you check? Did you pull a line when priming the pump? Did you check the pressure after the fuel filter? Did you pull the plugs after a failed start and confirmed fuel in the cylinder?

Also, since it's a new (to you) car, be sure to check EVERY fluid. Unless you know the PO and are familiar with the car, you can't trust their word. Oil, coolant, trans/rear diff fluid, power steering, and brake fluids. Also check/clean/replace the air filter. It might not hurt to run a can of seafoam through the fuel tank.
 

·
Registered
99 2.5 rs
Joined
·
6 Posts
Discussion Starter #3
yeah the IACV.

so when it doesn't start, it still turn over every time for as long as i hold the ignition over for.

we pulled the line off the fuel filter, and turned the car over and got fuel, my friend was helping me with that part i was the one in the car.

i changed the oil already(royal purple). checked the rest and top them off, put a new knock sensor on it. good idea on the air filter, (i was going to buy a intake) so i never replaced it, but ill check it.
 

·
Registered
99 2.5 rs
Joined
·
6 Posts
Discussion Starter #4
Thanks for the welcoming yarrgh, and the input. ill go check all the electrical connections and plugs, and clean the cam and crank sensor.

i was think of having a friend come over in his rs and taking his aicv out of his car and putting it in mine and seeing if it will start.

also i already ran a can of seafoam thru the tank.
 

·
Registered
1999 white impreza 2.5rs coupe
Joined
·
172 Posts
did you check the maf sensor? since its a 99. i had an issue with my 99 rs, it wouldn't start so i cleaned it and inspected the plug and wires and that was my issue.
 
1 - 5 of 5 Posts
Top