Subaru Impreza GC8 & RS Forum & Community banner

1 - 14 of 14 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
Swapped a 98 Subaru Legacy GT manual into a 99 Subaru Legacy GT Wagon only now with all the research over done the VSS still doesn't work. Tried tapping in the ECU, TCM, old transmission harness. Non of the wiring diagrams I have printed off of Mitchelln or All Data haven't pointed me in the right direction. Now I bought the Wagon with a no start found out it needed a fuel pump and relay to fix. So the vehicle didn't run before I get to swap so I have no idea if anything was wrong. It works with no problems except VSS and reverse lights. Below top pic connector is to my existing VSS, bottom pic connector is to the old automatic transmission
84287
84288
 

·
Super Moderator
2000 RSTi
Joined
·
1,159 Posts
99 is a wierd year, phase 1 engine, phase 2 transmission. And if you had the ej22 engine, it's a 1 year, all phase 2 electronics car with the old body.

If you want to make it work, you need to rip out the wiring and put the 98 under dash wiring in there.
 

·
Registered
1995 EZ30 Coupe
Joined
·
892 Posts
They only used the 2-wire VSS for 97-98, after that they went 3-wire. Get the correct sensor and wire it directly to the ECU.
You mentioned the car didn't run before you swapped it (living on the edge!) does the car currently run? If there only thing not working is the vss/reverse lights then you just need to plug the wires into the correct pins on those black and grey trans plugs. I wish I had pics of my old swapped bugeye...

Oh ya, 99 was a phase 1.5 I'd say, ej251 bottom end with ej25D heads. Factory hybrid ftw!
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #6 ·
The Subie runs and drives the gas was so old that smells like kerosene, hopefully that's the reason for the intermediate misfires.
 

·
Super Moderator
2000 RSTi
Joined
·
1,159 Posts
SoCoNoHa, how sure are you that rewiring the vss is all you need to run a 98 ecu and 5mt on a 99 wiring harness car (factory automatic)?

On my old 99 SUS, it wouldn't run on a 98 ecu, always was in limp mode. I had to find the correct 99 ej25d ecu to run it.
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #9 ·
Running the 98 ECU now but according to the wiring diagrams the old automatic had two VSS's now I've looked at the wiring diagrams for the 98 ECU which said pin 84 is the signal wire for the VSS but tapped in still have now VSS. Been using my Cell GPS/Speedometer to drive
 

·
Super Moderator
2000 RSTi
Joined
·
1,159 Posts
Yeah my 99 SUS physically also drove with the 98 ecu, but it wasn't right. I suspect if you could find a 99 ej25d 5mt ecu, and have the appropriate speed sensor in the new trans, it would solve the issue.
 

·
Registered
1995 EZ30 Coupe
Joined
·
892 Posts
I didn't see these replies, sorry. I was just referring to getting the speedometer to work, my suggestion assumes any other auto to manual swap wiring has been done.

I sometimes use a 99 LGT ecu I'm my 97 LGT and the only problem is a CEL because my fuel tank doesn't have a temp or pressure sensor. Car drives perfect, so the ECU's should be compatible. If the car doesn't run properly I would assume a wiring error or a bad ECU, I've had many of those.
 

·
Registered
1995 EZ30 Coupe
Joined
·
892 Posts
If you're using the 2 wire speed sensor with the 98 ECU, the speed signal has to go to the CLUSTER. There is an output from the cluster to the ECU. There's a computer in the cluster that translates the signal for the ECU/TCU.

Actually, if you do that it shouldn't matter what ECU you use, as they both see the same signal. The signal coming from the cluster should be useable by either ECU.

The 2 wire sensor needs to be converted by the cluster, the 3 wire can go straight to the ECU. Sorry I forgot about that earlier.
 

·
Registered
1995 EZ30 Coupe
Joined
·
892 Posts
You most likely will need the 97-98 cluster to convert the signal, but I could be wrong.
 

·
Registered
Joined
·
10 Posts
Hello there! Did you get the 2 wire VSS to work? I am encountering a similar issue. 5mt swap to my 2000 JDM forester S/Tb. Current MT tran came with a 2 wire VSS, having trouble with the speedo to work.
 
1 - 14 of 14 Posts
Top