Subaru Impreza GC8 & RS Forum & Community banner

121 - 140 of 271 Posts

·
Registered
99 RBP Coupe
Joined
·
551 Posts
Discussion Starter #122
Here is my new radiator & fan set up. I've decided to stick with a GD radiator so I can keep AC and have the nipple for the turbo coolant reservoir tank hose. There's about 1.5cm of clearance between the fan and the crank pulley.

Here are the items that I've used:
1 ea - Mishimoto WRX STI aluminum radiator
2 ea - Mishimoto 12" slim fans (removed fan motor spacer)
2 ea - Mishimoto fan mounting kits
1 ea - Subaru OEM upper radiator hose
1 ea - Subaru OEM lower radiator hose
1 ea - Random bottle for temporary overflow
1 ea - Aluminum flat bar, 1" wide

Pictures:




A couple notes:
1. Don't bother getting the Mishimoto radiator shroud. My buddy is using one in his Forester swap and he only has a few millimeters of clearance between the fan and the crank pulley.
2. Both hoses have been trimmed about 1cm to 1.5cm.
3. IMO, don't bother with silicone hoses. I've had issues with them seeping coolant. For my buddy's Forester swap, we ran into clearance issues.
4. Remember to use zip ties hold back your upper radiator hose from the alternator pulley unless you want it to rupture on the highway.

So far, I have no issues with cooling and I've even taken the car for a 831km road trip into the interior of British Columbia.
did some more digging and found this. i think im going to pull the trigger on the mishimoto fans
 

·
Premium Member
2001 2.5rs
Joined
·
2,295 Posts
From my understanding peeps have bent the A/C high line in order to make the usdm rs compressor work
that's what I did, I only had to bend it a little bit to clear the bracket that covers up the fuel injectors. I also reused the RS A/C compressor bracket.
 

·
Registered
99 RBP Coupe
Joined
·
551 Posts
Discussion Starter #124
that's what I did, I only had to bend it a little bit to clear the bracket that covers up the fuel injectors. I also reused the RS A/C compressor bracket.
yeah, i had to grab the bracket from the junk yard since i sold NA motor. the next swap i do i wont throw anything away or sell stock rs parts.
 

·
Premium Member
2001 2.5rs
Joined
·
2,295 Posts
That is for the front o2 sensor. The uppipe has an egt sensor and is and orange plug with two wires. My tuner just deleted mine because I switched to a catless one with no sensor. You can go that route or I can sell you mine. Or I can sell you the complete catted uppipe with the sensor
 

·
Registered
99 RBP Coupe
Joined
·
551 Posts
Discussion Starter #127
That is for the front o2 sensor. The uppipe has an egt sensor and is and orange plug with two wires. My tuner just deleted mine because I switched to a catless one with no sensor. You can go that route or I can sell you mine. Or I can sell you the complete catted uppipe with the sensor
than do i have the wrong sensor then? Untitled by Tyler Kirkland, on Flickr
 

·
Premium Member
2001 2.5rs
Joined
·
2,295 Posts
that is probably the front o2, do you have a pic of the sensor and where it is installed?


this is how it all looks
 

·
Registered
99 RBP Coupe
Joined
·
551 Posts
Discussion Starter #129
I found a ziploc bag of connections that i pulled off the motor. Thankfully the correct harness plug for the correlating sensor plug was in there so all i have to do is re-pin the found treasure. waiting for the fans to arrive. the boost gauge has been officially soldered in. hellas are in just have to connect the last wire , the switch. i looked more closely at my up pipe and didn't see anything like what you have?
 

·
Registered
2001 Impreza 2.5RS Sedan
Joined
·
643 Posts
Front O2 is in the manifold, the sensor right before the turbo in the up-pipe is an EGT sensor. Later (05+?) removed the EGT sensor from the up-pipe.
 

·
Registered
1995 STIL Wagon
Joined
·
346 Posts
I didn't use the springs. Mine came with some sticky foam pads. One on each corner then the plastic ties without springs. Holds them very well.

Foam pads ( left side of the fan) keep it from resting on the radiator and the plastic clips stay tight
 

·
Registered
99 RBP Coupe
Joined
·
551 Posts
Discussion Starter #133
the clips were trash they wouldnt work like a zipte they would slide right back off so i just bought some hayden brand at the local parts store and they worked perfect and were half the cost. not only that but the materials diameter was more thin so my fins dont get to beat up
 

·
Registered
99 RBP Coupe
Joined
·
551 Posts
Discussion Starter #134
Well after working on the car yesterday, the engine bay is buttoned down. now i want to comb through the car and double check all my lugs,bolts,nuts to make sure they are tight.

next up is to prime it and get it goijng.
 

·
Registered
99 RBP Coupe
Joined
·
551 Posts
Discussion Starter #138
lol i had some catching up to do as far as my classes go, im trying to digest the definitive integral , projectile motion, enthalpy, and solidworks. lots of assignements and preparations for midterms before spring break. tomorrow im taking a physics exam and then hope to have some kind of results to post up in the evening.
 
121 - 140 of 271 Posts
Top