Subaru Impreza GC8 & RS Forum & Community banner

1 - 6 of 6 Posts

·
Registered
2017 WRB BRZ w/PP
Joined
·
1,739 Posts
Discussion Starter #1
I just talked to my guy at the garage. I'm having the 2pots installed using the backing plates instead of the KB adapters. He's telling me the rotors are hitting the backing plates. Does anyone have any ideas as to why this might be happening? I've never heard of anyone having this problem when installing these using the backing plates. I'm heading over there after work today to have a look. Any help or insight anyone has would be greatly appreciated.

Thanks,

-bob
 

·
Registered
2016 Golf R
Joined
·
219 Posts
Err... is it the dust shield or backing plate? I dont see any reason why it would rub the backing plate.
 

·
Registered
2017 WRB BRZ w/PP
Joined
·
1,739 Posts
Discussion Starter #4
xaijin said:
Err... is it the dust shield or backing plate? I dont see any reason why it would rub the backing plate.
I believe its actually a dust sheild, but I've heard it referred to as both.
 

·
Registered
2016 Golf R
Joined
·
219 Posts
Yeah, just get a dremel and cut the lip off the dust shield. It's welded onto the backing plate, so it'll be a little hard to remove it.
 

·
Registered
2017 WRB BRZ w/PP
Joined
·
1,739 Posts
Discussion Starter #6
Went there after work and it turns out he just had to tweak the backing plate a little bit, I guess the fit around the hub is pretty snug, couple taps with a hammer while wrenching down fixed it. Bad news is I need a new drivers rear ABS sensor, thing was corroded all in and snapped in half when he tried to get it out, even while being "careful". Good news for me tho, get my car back tomorrow morning with my 4/2 upgrade complete and new wheel bearings just in time for this weekends AutoX. Thanks North Ursalia & xaijin for the suggestions.
 
1 - 6 of 6 Posts
Top