Subaru Impreza GC8 & RS Forum & Community banner

1 - 8 of 8 Posts

·
Registered
2003 impreza Rs silver
Joined
·
17 Posts
Discussion Starter #1
I have a 2003 Rs impreza with 228kms on the clock it has always been serviced every 5000kms with expensive full syn oil and always used 95 fuel. It has headers and cat back exhaust system with Bosch platnoum fusion 4 prong spark plugs. Ever since I put the Bosch plugs in it has had hesitation on start up when engine is cool. Could it be the plugs or maybe something else?
 

·
Registered
Black 2001 RS
Joined
·
787 Posts
These engines seem to like NGK spark plugs. They're fairly cheap and would be an easy test.
 

·
Registered
2003 impreza Rs silver
Joined
·
17 Posts
Discussion Starter #4
Yeah mine stumbles when cold aswell? What sort of ngk plugs does anyone recommend? Iridium or standard ?
 

·
Registered
2003 impreza Rs silver
Joined
·
17 Posts
Discussion Starter #5
Just replaced with ngk iridium brk6eix 1.1 gap plug and a new set of ignition leads still got the same problem.
 

·
Registered
2003 impreza Rs silver
Joined
·
17 Posts
Discussion Starter #6
Can anyone please tell me what else this could be it seriously sounds like a carburettor fed engine on cold start up. Once it's started no other problems goes fine. Soon as engine stops running and sits for about 3 hours it is a pig to start what could it be anyone know?
 

·
Registered
2000 2.5RS/C BRP
Joined
·
2,321 Posts
Do you have an OBD2 reader of some type that gets live data? If so, use it to check the reported ECT (coolant temp). If that sensor's going bad, it could be causing the ECU to run rich from too much cold enrichment.
 

·
Registered
2003 impreza Rs silver
Joined
·
17 Posts
Discussion Starter #8
Just gonna replace coolant temp sensor the one with brown plug two wires I'm pretty sure that's the one that feeds the ecu
 
1 - 8 of 8 Posts
Top