Subaru Impreza GC8 & RS Forum & Community banner

1021 - 1028 of 1028 Posts

·
Premium Member
2001 SRP 2.5RS/RA/SOHC Monster
Joined
·
2,734 Posts
I don't run the coolant expansion tank either but I still am using that port for one of the turbo coolant lines. I know I'm using both of the ports on the right side of the water pump. Here's a couple pictures.





 

·
Premium Member
2001 Subaru Impreza L coupe
Joined
·
770 Posts
Discussion Starter #1,023
Website won’t let me quote you...

but I don’t need the extra ports for anything. Ideally, if I was running an aftermarket oil cooler, a single port water pump would be perfect, but that doesn’t exist (I don’t think). My turbo is oil cooled only, so I just need one port on the right for the heater core, and the one on the left for the oem cooler.

The unused ports are easy enough to cap off though. It’s the suction side of the pump. If I ever delete the factory cooler I’ll just cap that one like I did for the coolant tank.
.
 

·
Premium Member
2001 Subaru Impreza L coupe
Joined
·
770 Posts
Discussion Starter #1,024
Got some parts gathered up to get me going. Still deciding on some things, like the oil cooler thing, and some other stuff, but I should be able to get some progress on the engine this weekend. I want to get it in the car before it gets too cold out, but I’m not gonna rush it.

Had to get a new sti pan. The one on my spare motor was so suck from the RTV I had to mangle it to get it off.



Changing up the exhaust slightly. I really want an EL header but don’t wanna pay for one, and didn’t want to stay with a 100% stock header, so this was a decent compromise.

Grimmspeed crosspipe, and I’m gonna DIY port the cast collectors. Should flow a little more. Time to burn out my Dremel. I’m sure it’ll love grinding cast iron lol.





 

·
Premium Member
2001 Subaru Impreza L coupe
Joined
·
770 Posts
Discussion Starter #1,025 (Edited)
Built motor is going back to the machine shop. Multiple concerning things. So annoyed.

I’m about done with this shit. Lost all motivation over the last year. Not fun anymore. I try my best to avoid this stuff, but something out of my control always messes things up.
 

·
Premium Member
2001 Subaru Impreza L coupe
Joined
·
770 Posts
Discussion Starter #1,027
Shit, that sucks. Mind sharing what they fucked up?
Not 100% sure if there’s actual problems yet. Something doesn’t seem right to me, and hopefully it’s nothing, but they want it back to take a look.

My main concern is where the oil pump bolts to the block. The case halves don’t meet perfectly for some reason. I took the oil pump back off to check something, and noticed damage to the mating surface of the pump. It was a brand new oil pump, so the block definitely damaged the pump’s surface. The damage is right where the seam of the block is. I can easily catch a finger nail on the seam. Should be dead flat.

I only noticed that because I took the pump back off to check another possible issue. So I’m lucky I found it, but still annoying. Obviously worried about the pump leaking and stuff. Photos below:







 

·
Registered
2001 SRP RS Coupe, 05 FXT
Joined
·
297 Posts
Yeah, that doesn't seem right. It's like the put a chisel in between the case halves at the seam
 
1021 - 1028 of 1028 Posts
Top