Subaru Impreza GC8 & RS Forum & Community banner

1021 - 1031 of 1031 Posts

·
Premium Member
2001 SRP 2.5RS/RA/SOHC Monster
Joined
·
2,778 Posts
I don't run the coolant expansion tank either but I still am using that port for one of the turbo coolant lines. I know I'm using both of the ports on the right side of the water pump. Here's a couple pictures.





 

·
Premium Member
2001 Subaru Impreza L coupe
Joined
·
773 Posts
Discussion Starter #1,023
Website won’t let me quote you...

but I don’t need the extra ports for anything. Ideally, if I was running an aftermarket oil cooler, a single port water pump would be perfect, but that doesn’t exist (I don’t think). My turbo is oil cooled only, so I just need one port on the right for the heater core, and the one on the left for the oem cooler.

The unused ports are easy enough to cap off though. It’s the suction side of the pump. If I ever delete the factory cooler I’ll just cap that one like I did for the coolant tank.
.
 

·
Premium Member
2001 Subaru Impreza L coupe
Joined
·
773 Posts
Discussion Starter #1,024
Got some parts gathered up to get me going. Still deciding on some things, like the oil cooler thing, and some other stuff, but I should be able to get some progress on the engine this weekend. I want to get it in the car before it gets too cold out, but I’m not gonna rush it.

Had to get a new sti pan. The one on my spare motor was so suck from the RTV I had to mangle it to get it off.



Changing up the exhaust slightly. I really want an EL header but don’t wanna pay for one, and didn’t want to stay with a 100% stock header, so this was a decent compromise.

Grimmspeed crosspipe, and I’m gonna DIY port the cast collectors. Should flow a little more. Time to burn out my Dremel. I’m sure it’ll love grinding cast iron lol.





 

·
Premium Member
2001 Subaru Impreza L coupe
Joined
·
773 Posts
Discussion Starter #1,025 (Edited)
Built motor is going back to the machine shop. Multiple concerning things. So annoyed.

I’m about done with this shit. Lost all motivation over the last year. Not fun anymore. I try my best to avoid this stuff, but something out of my control always messes things up.
 

·
Premium Member
2001 Subaru Impreza L coupe
Joined
·
773 Posts
Discussion Starter #1,027
Shit, that sucks. Mind sharing what they fucked up?
Not 100% sure if there’s actual problems yet. Something doesn’t seem right to me, and hopefully it’s nothing, but they want it back to take a look.

My main concern is where the oil pump bolts to the block. The case halves don’t meet perfectly for some reason. I took the oil pump back off to check something, and noticed damage to the mating surface of the pump. It was a brand new oil pump, so the block definitely damaged the pump’s surface. The damage is right where the seam of the block is. I can easily catch a finger nail on the seam. Should be dead flat.

I only noticed that because I took the pump back off to check another possible issue. So I’m lucky I found it, but still annoying. Obviously worried about the pump leaking and stuff. Photos below:







 

·
Registered
2001 SRP RS Coupe, 05 FXT
Joined
·
314 Posts
Yeah, that doesn't seem right. It's like the put a chisel in between the case halves at the seam
 

·
Premium Member
2001 Subaru Impreza L coupe
Joined
·
773 Posts
Discussion Starter #1,029
I feel bad not doing updates on here lately....even though I haven’t been doing shit. :lol:

Currently posting this on my way to the Rolex24. Long drive from PA. Definitely gonna start working on the cars again when I get back....but I’m pretty hyped for this race. Got an infield campsite, and plenty of DSLR batteries to shoot photos all weekend. First time going to the Rolex24 so should be a good time.





Minor car updates:

Coupe is still running good at 20psi. Just been having fun driving it on the weekends. There’s some more weight reduction I wanna do soon, and some general maintenance stuff.

The built motor is wrapped up and ready to go back to the machine shop.....still really annoyed about the whole situation. Haven’t had time to drop it off yet, because it’s hard to fit an engine in my vehicles, and the shop is 1.5 hours from my house. Hopefully it gets fixed and I can get it in the car by spring. Just want like 400-450whp.






My swapped sedan is almost ready for inspection finally. It’s been sitting with emissions problems for over a year now.....but I swapped to an 02 ecu so I can finally get it through inspection. Also started working on converting it to open source instead of Cobb.

Should finally be ready to daily soon, after swapping it almost 2 years ago. :lol:





And the brz is still the main daily....and I still love it. Slow, but so damn fun/enjoyable to drive. Handles so well. Still 100% stock too. No planned mods because I’m cheap/lazy.

Made me realize how nice a proper RWD chassis is. I’ll probably be getting another RWD car for a new project in the next 1-2 years. RWD is too fun.

 

·
Registered
Turbo, LS swapped Impreza RS
Joined
·
5,171 Posts
So the shop finally owned up to there being an issue?

Sent from my SM-N920V using Tapatalk
 

·
Premium Member
2001 Subaru Impreza L coupe
Joined
·
773 Posts
Discussion Starter #1,031
So the shop finally owned up to there being an issue?

Sent from my SM-N920V using Tapatalk
Replied to your text. But they think, based off the photos, that it happened after assembly between their shop and my house. But there’s no way that damage could’ve happened once the case halves were together. I think it happened before they assembled it.
 
1021 - 1031 of 1031 Posts
Top