Subaru Impreza GC8 & RS Forum & Community banner

21 - 40 of 51 Posts

·
Registered
1999 Impreza 2.5RS "RuSTI"
Joined
·
83 Posts
There is voltage drop when the key is turned. It goes from 12V to around 8-9V. Im guessing it could just be a connection issue then. The two grounds at the top of the strut are good. I just need to check the rest. I heard there are some underneath the dashboard that have caused people issues. I'm not sure where but I will take a look later today after work. Thank you guys for all of the support. I do appreciate it.
TO AROUND 8 OR 9V??
It would be dropping to around 11.4v at the most. Gotten your battery tested? That sounds like it might be the issue.
 

·
Registered
2000 Subaru 2.5RS
Joined
·
29 Posts
Discussion Starter #22
The battery got tested last weekend when this first happened. And when I read the voltage on my dvom it reads out 12V.
 

·
Registered
2000 Subaru 2.5RS
Joined
·
29 Posts
Discussion Starter #24
Yes the starter was checked and tested. It brand new too but I still wanted it tested and they told me it was good. I'm not sure if maybe the battery cables or something else is probably not giving off a good connection.
 

·
Registered
1999 Impreza 2.5RS "RuSTI"
Joined
·
83 Posts
Where do you think I should start?
Check battery terminals to make sure they're contacting the battery well, check the wires to the starter for excess resistance, check all the grounds, check the starter relay, other than those I'm not sure
 

·
Registered
2000 Subaru 2.5RS
Joined
·
29 Posts
Discussion Starter #28
Ok. Thanks bro. This car has been a freaking headache this past couple of days.
 

·
Registered
2000 Subaru 2.5RS
Joined
·
29 Posts
Discussion Starter #30
Ok guys I got the car started up, it was the ignition switch. It hesitates when cranking but it starts up. Smoke does come out of the starter so I'm going to get it replaced. It has warranty. The car does turn off on me and doesn't accelerate as it should. And I noticed it was overheating I'm not sure if that has anything to do with it turning off.
 

·
Registered
1999 Impreza 2.5RS "RuSTI"
Joined
·
83 Posts
Ok guys I got the car started up, it was the ignition switch. It hesitates when cranking but it starts up. Smoke does come out of the starter so I'm going to get it replaced. It has warranty. The car does turn off on me and doesn't accelerate as it should. And I noticed it was overheating I'm not sure if that has anything to do with it turning off.
Does it actually overheat, like steam coming out the radiator overheating, or does the garage just say it does, because if just the garage says it does could be coolant temp sensor. Strange that it's down on power though, any engine codes?
 

·
Registered
2000 Subaru 2.5RS
Joined
·
29 Posts
Discussion Starter #32
No steam coming out of radiator. The gauge is just showing. And the codes in the system are P0325, and P1133
 

·
Registered
2000 Subaru 2.5RS
Joined
·
29 Posts
Discussion Starter #34
Ok I’ll take a look at it after work. Thanks! I’m happy she is running again. Just need a few more things until she is back on the road for good.
 

·
Registered
2000 Subaru 2.5RS
Joined
·
29 Posts
Discussion Starter #36
I hope you’re right. Rather replace the knock sensor and get it over with,
 

·
Registered
2000 Subaru 2.5RS
Joined
·
29 Posts
Discussion Starter #37
Hey guys ok so the car still hesitates to start at times like if there isn't enough power going through. I'm thinking of getting a new battery to cable. But also the car dies at idle when you rev the car and let go. There is a leak in the intake manifold but I am not sure if that is what is causing it to die.
 

·
Registered
1999 Impreza 2.5RS "RuSTI"
Joined
·
83 Posts
Hey guys ok so the car still hesitates to start at times like if there isn't enough power going through. I'm thinking of getting a new battery to cable. But also the car dies at idle when you rev the car and let go. There is a leak in the intake manifold but I am not sure if that is what is causing it to die.
Don't know if you have the ej251 or ej253(MAP vs MAF sensor) but if you have the MAF it will 100% cause the car to struggle to idle and even die if there's an intake leak
 
21 - 40 of 51 Posts
Top