Subaru Impreza GC8 & RS Forum & Community banner
1 - 3 of 3 Posts

·
Registered
1996 Subaru WRX
Joined
·
1 Posts
Discussion Starter · #1 ·
Recently inquired from all the experts on this page and I really appreciate all the feed back.

Overview and update.
Was driving just fine. Went to fill up. Drove around a bit more 20-30 min. Had a complete loss of power. (As in while driving the engine cut off and would not rev when the gas pedal was pressed) pulled over.
Attempted to start the car. The engine started up like a champ but emediatly died. Same result time and time again. Got her towd home. Turned on the ACC and for sure can hear the fuel pump activate (make the little whine sound). Disconnected the fueline from fuel filter inlet. Turned on ACC. Fuel squirts out. Reconnected filter inlet. Disconnected fuel line frome fuel filter outlet. Turned on ACC. Fuel squirts out. Reconnected fuel lines. Disconnected MAF sensor plug and started the car. Dies within a second or two. Reset the ECU by leaving some lights on and disconnected battery terminals left to sit overnight pressed to break pedal a few times for good measure reconnected battery terminals and started her up. Same result as before. Tried a new coil pack as well. Same result.
Currently I have removed the Air Idle Control Valve, gained access to the throttle body and removed the PCV valve. I'm going to clean the throttle body and AICV with carb cleaner and replace the PCV valve.

What if anything more should I try? Is it possible for the fuel pump to prime with acc but not send fuel when the throttle is pressed? It must be getting at least some fuel to at least get the motor to turn over.

Additional info that may narrow things down-
I can keep the engine on a bit longer if I LIGHTLY flutter the throttle. If I open it up all the way it dies like usual. When I do this I can here popping sound come from the intake.
It has a new fuel pump and a new MAF sensor new spark plugs and wires as well.

Fresh update. Removed cleaned the air idle control valve and reinstalled. Same result. Cleaned the throttle body. Same same. Replaced the PCV valve. Same result. Will idle longer and at a higher rev with starter fluid spray on the intake.

Maybe a throttle position sensor? Get a fuel pressure check? Replace fuel pressure regulator? I'm shooting in the dark. Thanks for the help and interest!
1996 WRX. EJ20K.
 

·
Registered
Joined
·
194 Posts
Have you tried disconnecting upstream o2 to force open loop to see how it idles?

Checked injectors to see if any of them are cutting out? If gas is good and fuel pressure is good then it might be injectors possibly.

Can also check to see you have spark at all cylinder.
 
1 - 3 of 3 Posts
Top