Subaru Impreza GC8 & RS Forum & Community banner
1 - 7 of 7 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
so today i drove to work at 5am, it was 7 degress out and when i left work at 2pm i drove to the local store for errands, it felt like it was negative outside. when i was leaving the store, i started the car and it wouldnt start. there was power but sooner or later the power died. i jump started it and drove home and when i tried to start it it wouldnt start. so i went to buy a new battery and it still wont start unless its jump.
 

·
Registered
2000 RS
Joined
·
686 Posts
You should have had the battery checked before replacing it. Have the alternator checked. It's odd though, because if the alternator is bad, the battery would die off quick as well. Maybe it's not working at its full potential.
 

·
Registered
2000 EJ257 Swapped RS
Joined
·
548 Posts
Could also be a bad ground. When you jumped it you could have been grounding through the other car therefore making you think it was the battery. Follow your grounds from the (-) terminal of your battery and unbolt them and clean them up. Also make sure the terminal itself is nice and clean. Round wire brush or run to the automotive store and get a terminal cleaner. If that doesnt work have your alternator tested and go from there. Good luck.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #6 ·
idk, what the problem is. well the termal does have white stuff on it. and it still wont start up today. this is the first time it happen to me and it was the coldest i drove with my car b4
 

·
Registered
1995 Impreza L / 2001 2.5 RS
Joined
·
87 Posts
Clean your Battery terminals and re install them nice and tight. Even the smallest bit of corrosion can cause little, to no connection to your battery, which can drain/kill it very quickly
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top