Subaru Impreza GC8 & RS Forum & Community banner

1 - 5 of 5 Posts

·
Registered
2000 2.5Rs
Joined
·
10 Posts
Discussion Starter #1
00 RS w full 2006 motor, drivetrain and ECU swap w Spiider DCCD controller

I'm at my wits end so hopefully this community can help like usually when I'm at this point. So the short story is I'm not getting power to my ECU. 3 weeks ago my car ran and drove before the ECU shorted out and fried the board. IDK what caused it but now it's a real issue. I purchased a used ECU with matching immobilizer, ignition and key. I've replaced EVERY fuse. I just bought all new fuses including the ones in the engine bay. I've replaced the main relay and the fuel pump relay still no power. I've supplied power and ground to the fuel pump and controller and the pump ran so I know they work. The CEL won't come on in the 06 cluster and it used to. My Accessport won't connect. I've checked continuity at the starter, transmission, intake and 2 other body grounds and I'm getting signal. The fuel pump controller is getting power and is grounded to the body but isn't getting a signal from the ECU.

Having said all that is there a way to check the immobilizer and ECU to make sure the used version are good? Where else should I test? Any thoughts or suggestions I would appreciate. Thanks community!

IG: DIYRSTI
 

·
www.jackstalk.com
‘98 RS, 911 Cab, CT6 TT, Escalade ESV
Joined
·
5,625 Posts
I would try running power directly to the ECU from the fusebox via a jump wire to see if it turns over.
 

·
Registered
2000 2.5Rs
Joined
·
10 Posts
Discussion Starter #3
Hmm ok. I didn't think I could do that because of the immobilizer. I thought it had to send an ok signal. But now that I think about, do you mean key in the on position then an additional power from the battery direct?
 

·
Registered
1995 EZ30 Coupe
Joined
·
800 Posts
On the intake manifold there should be a bolt or two that grounds the engine wiring harness. I've had similar problems due to a dirty connector, specifically the one that connects the engine ground to the ECU. Anyway, grounds can be a pain.

Do you have the plastic wheel well liners? I lost the driver's front liner in my bugeye and water eventually made it to the interior fuse panel because of it. Caused all kinds of hell.

Good luck!
 

·
Registered
2000 2.5Rs
Joined
·
10 Posts
Discussion Starter #5
Currently the car doesn't have any liners but it doesn't have doors or bumpers or lights either haha. I only drove it once to down the street so I know it runs. All of a sudden I had a short and now this issue. I'm going to try a jumper wire to manually ground the ECU and see if it cycles. I'll be in touch.
 
1 - 5 of 5 Posts
Top