Boosting 1990-2002 USDM Subarus: A Chronological Guide - Page 11 - Subaru Impreza GC8 & RS Forum & Community: RS25.com
 
Private Support i-Trader Ratings Become a Vendor Rules for VendorsModsUsers Contact
Subaru Impreza GC8 & RS Forum & Community: RS25.com
gc8 RSS GC8 Facebook Subaru GC8 Twitter Subaru YouTube Channel Subaru Sticker
 
Login below or Register Now
Register Mark Forums Read FAQ Advertise
Go Back   Subaru Impreza GC8 & RS Forum & Community: RS25.com > >
Boosting 1990-2002 USDM Subarus: A Chronological Guide
Reply
 
Thread Tools Display Modes
Old 02-26-2014, 06:20 AM   #101
Hydrochloric
2.2L Turbo
 
Car: 2000 2.5RS/C BRP
Fav Mod: M62 Boostin'!
Join Date: Feb 2010
Location: Cap. Region/North Country NY
Trader Rating: (3)
Posts: 2,321
Default

Quote:
Originally Posted by pjr203 View Post
Question: you said never pressurize your emission lines? I recently turbo charged my 2000 rs and everything went well after I drove it around except a puddle of oil was in my intake filter coming from the turbo. I left the breather hoses coming from the valve covers just hanging in the engine bay so they weren't seeing vaccum, could this be why I got oil spitting out of the inlet of the turbo or are the seals on the turbo no good? Also my boost gauge wasn't reading any boost and everything's hooked up properly but There sure is boost! Thanks for your help Its really appreciated!
Never pressurize, ideally they see pre-boost vacuum. However, leaving them disconnected should be fine. At low RPM/boost the breathers take air in, but at high RPM/boost the breathers expel air, hence why it should be behind a filter. Think about old V8s, they just had little filters on the valve covers.
__________________
'93 Audi S4 -'00 2.5RS/C RIP -'96 Jag XJS 4.0 -'83 944 -'66 VW Type III -'50 Commodore 6
Hydrochloric is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 02-26-2014, 09:09 AM   #102
pjr203
1.8L
 
Car: 2000 impreza rs blue
Fav Mod: borla exhaust
Join Date: Aug 2010
Location: connecticut
Trader Rating: (2)
Posts: 16
Default

Quote:
Originally Posted by flyboynextdoor View Post
Do you have an oil pressure gauge and if so how much pressure are you showing? What turbo are you running? Two things could be wrong there.
The turbos seals could be gone yep. Or the slim chance you're running too much pressure for whatever turbo you're using and it's blowing by the seals. You also never mentioned your Crankcase vent. Where is it going??
I'm running a tdo4 and I don't have an oil pressure gauge. I have the crankcase vent going to the intake in between the filter and turbo, but looking down the hose with a flashlight it didn't seem to have much oil in there.
__________________
philthephilosopher
pjr203 is offline   Reply With Quote
Old 02-26-2014, 09:14 AM   #103
Herm99
2.5L
 
Car: 99 OBS
Join Date: Nov 2008
Location: Missoula, MT
Trader Rating: (1)
Posts: 276
Default

Some blow-thru is normal, turbo's typically consume some oil, how much you are seeing is the question. Can you post a pic of your intake where the oil is collecting?
__________________
99' OBS (2.2) 4EAT /// 01 Audi S4 - 2.7 Twin Turbo - 520AWHP/512 ft lbs
Herm99 is offline   Reply With Quote
Old 02-26-2014, 11:38 AM   #104
pjr203
1.8L
 
Car: 2000 impreza rs blue
Fav Mod: borla exhaust
Join Date: Aug 2010
Location: connecticut
Trader Rating: (2)
Posts: 16
Default

I already cleaned it up:/ but it was a lot. There was a puddle the size of ur hand under the intake filter
__________________
philthephilosopher
pjr203 is offline   Reply With Quote
Old 02-26-2014, 09:21 PM   #105
flyboynextdoor
2.0L Turbo
 
Fav Mod: DIY Aerosim widebody!
Join Date: Jun 2011
Location: Penticton, British Columbia
Trader Rating: (4)
Posts: 1,312
Default

Quote:
Originally Posted by pjr203 View Post
I already cleaned it up:/ but it was a lot. There was a puddle the size of ur hand under the intake filter
That is alot, how much play in that turbo shaft? it sounds like that s***** is hemorrhaging oil.

really Succer gets censored? WTF?
flyboynextdoor is offline   Reply With Quote
Old 03-24-2014, 08:34 PM   #106
pjr203
1.8L
 
Car: 2000 impreza rs blue
Fav Mod: borla exhaust
Join Date: Aug 2010
Location: connecticut
Trader Rating: (2)
Posts: 16
Default

Quote:
Originally Posted by flyboynextdoor View Post
That is alot, how much play in that turbo shaft? it sounds like that s***** is hemorrhaging oil.

really Succer gets censored? WTF?
Put a new vf39 on and still getting the same thing. High oil pressure maybe? I'm using the stock banjo bolt, is there another oil restricter idk about? Is it my crank case vent? Could it be cuz I tapped my valve cover for the oil return and it's backing up?
__________________
philthephilosopher
pjr203 is offline   Reply With Quote
Old 03-25-2014, 11:58 AM   #107
flyboynextdoor
2.0L Turbo
 
Fav Mod: DIY Aerosim widebody!
Join Date: Jun 2011
Location: Penticton, British Columbia
Trader Rating: (4)
Posts: 1,312
Default

Quote:
Originally Posted by pjr203 View Post
Put a new vf39 on and still getting the same thing. High oil pressure maybe? I'm using the stock banjo bolt, is there another oil restricter idk about? Is it my crank case vent? Could it be cuz I tapped my valve cover for the oil return and it's backing up?
The valve cover shouldnt be backing up unless there is a significant length of hose below the level of the drain into the valve cover. If youve got a new turbo with good seals on then it sounds like youre getting alot of blowby in your vac system and a catch can is needed.
flyboynextdoor is offline   Reply With Quote
Old 04-07-2014, 12:13 AM   #108
ukr823f
1.8L
 
Car: Legacy BE
Fav Mod: Turbocharger:)
Join Date: Jan 2014
Trader Rating: (0)
Posts: 16
Default

Machine - Legacy 2000BE ej201, automatic - TZ1A4 ....
Turbine to be installed - TD04. Aspiration - 6psi

Well, now need help specialists. How can I merge two ECU to work together. I will stand AEM EMS, and on it, as we know it is not possible to connect the signal from TCU 4eat. Torque control 1 and torque control 2, as well as torque cut signal. So I want to leave a stock ECU for the transmission control all second corrector systems, and install a new ECU only for controlling ignition and injectors.
ukr823f is offline   Reply With Quote
Old 04-29-2014, 07:56 PM   #109
STI Prince
1.8L
 
Car: 1999,GC8, Silver
Join Date: Dec 2013
Location: Washington
Trader Rating: (1)
Posts: 15
Default

Is there a how to on how to connect everything together?
STI Prince is offline   Reply With Quote
Old 09-06-2014, 01:28 PM   #110
Magnus___andersson
1.8L
 
Join Date: Feb 2014
Trader Rating: (0)
Posts: 5
Default

building a legacy with ej20, i made it for the swedish winter

Last edited by Magnus___andersson; 10-12-2014 at 12:47 PM..
Magnus___andersson is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 05:16 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
Copyright © 2019 VerticalScope Inc.
Designed & Powered by Domain Architect