Nicole _ Another swap story - Page 25 - Subaru Impreza GC8 & RS Forum & Community: RS25.com
 
Private Support i-Trader Ratings Become a Vendor Rules for VendorsModsUsers Contact
Subaru Impreza GC8 & RS Forum & Community: RS25.com
gc8 RSS GC8 Facebook Subaru GC8 Twitter Subaru YouTube Channel Subaru Sticker
 
Login below or Register Now
Register Mark Forums Read FAQ Advertise
Go Back   Subaru Impreza GC8 & RS Forum & Community: RS25.com > >
Nicole _ Another swap story
Reply
 
Thread Tools Display Modes
Old 09-23-2016, 02:02 PM   #241
bue car
#32
 
bue car's Avatar
 
Fav Mod: Which car?
Join Date: Jun 2008
Location: Torrance, CA
Trader Rating: (173)
Posts: 11,852
Default

Good luck!
__________________
Save RS25! Say no to XenForo
bue car is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 09-29-2016, 01:14 PM   #242
steezin_and_wheezin
Premium Member
 
steezin_and_wheezin's Avatar
 
Fav Mod: ej205
Join Date: Mar 2008
Location: Dublin, VA
Trader Rating: (8)
Posts: 1,124
Default

Still sorting.. Was at a friends over the weekend and he had a decent meter with longer leads. ECU plug looked to have a little dust/dirt on it when I uncovered it, but he didn't have any contact cleaner.. --Remember to pull and clean that up just to rule out another dirty plug.

I managed to test all wires and received good conductivity from everything plug to plug(1->D4&D5, 3->D29, 4->D19). Found the SB wire and learned something new about sheilded braids and their function. Next is double check I don't get any continuity to ground from plugs. Rain is back in so I'm hoping to troubleshoot more next week. Going to see if I can work up another ecu to test and eliminate one more variable as well

Side note my leaks have seemed(knock on wood) to dry up! Had a serious flash flood roll through. Double checked - floorboard bone dry and even my door/window seals are looking good!
__________________
if your binder's ain't squeakin, you ain't tweakin!
steezin_and_wheezin is offline   Reply With Quote
Old 10-05-2016, 11:47 AM   #243
steezin_and_wheezin
Premium Member
 
steezin_and_wheezin's Avatar
 
Fav Mod: ej205
Join Date: Mar 2008
Location: Dublin, VA
Trader Rating: (8)
Posts: 1,124
Default

THIS IS NOT AN OPTICAL ILLUSION!!!


I repeat not an illusion!! I actually drove this amazing unit for the first time with no CEL since the swap. It'll bring a tear to yer eye.

Last night I ran out to a friends place to test the car with a 2002 ecu. Wanted to insure the ecu wasn't my root of the front o2 CEL. Swapped the ecu over and voila!! No light. After looking over the car with him - I wasn't thinking and hoped in to head home. Didn't think about running the stock mapped 02 ecu with my setup(including 3 port ebcs).. Only drove maybe 2 miles with it until I found a pull off spot. Swapped back over to my 04 ecu with stage2 map(cel light still came right back) and drove home. Unmarried my AP from the 04 and married to my 02 ecu. No problems, until I tried to load the ebcs map. The maps I had were 04 ecu specific.. Perfect timing for my internet to be on the fritz! So I couldn't get the map I needed last night. Net was back up today and I pulled the OTS stage 2 w/ebcs(normal and low wastegate) to test. Flashed on the map and spun her up. No light for ~5mins idling and still none after a ~20min haul. I'll take a longer drive after work as it seems most other lights like that 30 miles mark before showing it's face. Power is definitely up! I can tell it's no longer in 'limp' mode, feels much healthier ever when out of the boost. Boost is real, real strong.

For now I'm ecstatic! I traded my buddy a spare o2 sensor for the ecu, but I still need to do some more research any adverse effects of running the 02-03 ecu on my 04 engine with my 02 merged harness. I was hopeful when purchasing my donor car that I'd keep away from using different parts from this and that. Guess it's just the nature of the beast sometimes. Hope research shows 02-03 ecu is OK on my 04 engine. Then I can get all my interior back together.. again(not saying final time anymore)


On a high note, with running the 02-03 ecu I don't get either of my PCV or VSV codes!!
__________________
if your binder's ain't squeakin, you ain't tweakin!
steezin_and_wheezin is offline   Reply With Quote
Old 10-05-2016, 08:45 PM   #244
bue car
#32
 
bue car's Avatar
 
Fav Mod: Which car?
Join Date: Jun 2008
Location: Torrance, CA
Trader Rating: (173)
Posts: 11,852
Default

Interesting
__________________
Save RS25! Say no to XenForo
bue car is offline   Reply With Quote
Old 10-06-2016, 05:45 AM   #245
Bansheeboy11
I ❤ BOOBIES
 
Fav Mod: 300K Club
Join Date: May 2008
Location: New York
Trader Rating: (59)
Posts: 16,948
Default

What was the code for the O2? Some have to go through drive cycles before it throws a light. But the only difference between 02/03 and 04/05 is some vent solenoids for the gas tank that are different, 02/03 doesnt have them so you should be good to roll once you reflash your map onto it, but make sure you flash it as an 02/03.
__________________
Follow me @TheProjectCar
Bansheeboy11 is offline   Reply With Quote
Old 10-06-2016, 06:14 AM   #246
steezin_and_wheezin
Premium Member
 
steezin_and_wheezin's Avatar
 
Fav Mod: ej205
Join Date: Mar 2008
Location: Dublin, VA
Trader Rating: (8)
Posts: 1,124
Default

It was a p0130 o2 sensor circuit malfunction. Yup, 02/03 ecu actually works better for me as well since I've used a 2002 harness for my merge. With the 02 ecu my 2004 specific cel's(p1446 & p1491) haven't showed their face just yet. Only thing I've heard about, and I still need to do more research, is running the grey coil packs on the 2002 ecu. Terry found some info comparing the 02 and 04 ecu roms. This is a little over my head, but he said "There a cell in the CL to OL delay thats glitched. should be 366, in 02 its 3662". I'll look into that and be sure my tuner is aware that I'm running grey coils.

For now I'm running 2002/03 Cobb OTS stage2 map for 93 octane w/ebcs(normal wastegate). Running well so far, I took some logs on the commute in this morning. I'll glance at them later. Still waiting to hear back from Steven at IAP if it's possible to change which ecu he'll be tuning this late it the game. Since doing more reading I'm aiming to stay with the 02/03 ecu, but hoping it's not a huge deal for him. Hell would even pay a bit extra if he needs, would rather not have to run a 04 ecu with the pcv and vsv cel's defeated.

Have the weekend off, just need to finalize my best man speech for a wedding next weekend. Then hoping with the CEL off I can dig into a couple other ToDo list items
__________________
if your binder's ain't squeakin, you ain't tweakin!
steezin_and_wheezin is offline   Reply With Quote
Old 10-06-2016, 06:22 AM   #247
Bansheeboy11
I ❤ BOOBIES
 
Fav Mod: 300K Club
Join Date: May 2008
Location: New York
Trader Rating: (59)
Posts: 16,948
Default

The CL/OL delay should be zeroed out across the board, thats a known issue. The ECU doesnt have control over whats going on during that transition and can cause issues. Those 04 codes wont come up as they are not even in the 02 ECU, and regarding coil packs, you can just copy the ignition dwell from the 04+ rom, its a longer dwell fora slightly more powerful spark but the ECU needs to know that number to correctly start the timing advance.
__________________
Follow me @TheProjectCar
Bansheeboy11 is offline   Reply With Quote
Old 10-06-2016, 07:04 AM   #248
steezin_and_wheezin
Premium Member
 
steezin_and_wheezin's Avatar
 
Fav Mod: ej205
Join Date: Mar 2008
Location: Dublin, VA
Trader Rating: (8)
Posts: 1,124
Default

Top notch info mang!! Really helps connect the dots, many thanks
__________________
if your binder's ain't squeakin, you ain't tweakin!
steezin_and_wheezin is offline   Reply With Quote
Old 10-06-2016, 06:24 PM   #249
steezin_and_wheezin
Premium Member
 
steezin_and_wheezin's Avatar
 
Fav Mod: ej205
Join Date: Mar 2008
Location: Dublin, VA
Trader Rating: (8)
Posts: 1,124
Default

Steven at IAP just made my night. Since I'm running an accessport his map was specific to a 2004 ecu.. he's going to send a 2002 map and we can go from there. Working too much overtime lately and needed a good pick me up, definitely did the trick!

Small thing, only took weeks and a lot of cussing.. I finally popped the ebrake's center console piece out and tightened cable tension. I'm the king of bojangling on 5 min jobs..
__________________
if your binder's ain't squeakin, you ain't tweakin!
steezin_and_wheezin is offline   Reply With Quote
Old 10-06-2016, 08:06 PM   #250
bue car
#32
 
bue car's Avatar
 
Fav Mod: Which car?
Join Date: Jun 2008
Location: Torrance, CA
Trader Rating: (173)
Posts: 11,852
Default

Bojangling, been a minute, love it.

Sounds like you need yourself a little stash of weed
__________________
Save RS25! Say no to XenForo
bue car is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 02:13 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
Copyright © 2019 VerticalScope Inc.
Designed & Powered by Domain Architect