SoCoNoHa's Flavor of the Week - Page 6 - Subaru Impreza GC8 & RS Forum & Community: RS25.com
 
Private Support i-Trader Ratings Become a Vendor Rules for VendorsModsUsers Contact
Subaru Impreza GC8 & RS Forum & Community: RS25.com
gc8 RSS GC8 Facebook Subaru GC8 Twitter Subaru YouTube Channel Subaru Sticker
 
Login below or Register Now
Register Mark Forums Read FAQ Advertise
Go Back   Subaru Impreza GC8 & RS Forum & Community: RS25.com > >
SoCoNoHa's Flavor of the Week
View Poll Results: What engine should I put in my car?
EJ18 Block/EJ18 Heads 0 0%
EJ18 Block/EJ22T Heads 1 8.33%
EJ22 Block/EJ22T Heads 6 50.00%
EJ22 Block/EJ25D Heads 2 16.67%
EJ25 Block/EJ22T Heads 1 8.33%
EZ30D 3 25.00%
Other 3 25.00%
Multiple Choice Poll. Voters: 12. You may not vote on this poll

Reply
 
Thread Tools Display Modes
Old 04-27-2018, 06:40 PM   #51
SoCoNoHa
2.7L
 
Fav Mod: Anything custom
Join Date: Feb 2018
Location: Southern NH
Trader Rating: (1)
Posts: 439
Default

Quote:
Originally Posted by George.of.the.Jungle View Post
true story. all being told, i'm prolly in it about 1700 or to date. and about 500 of that is AEM gauges. so...
I'm pretty sure I'm well north of 2k at this point... but that's with buying things I didn't need to buy. I never intended to stick to a budget, this is just for funs!
__________________
97 LGT / 92 SVX / 95 GM∆
SoCoNoHa is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 04-28-2018, 01:06 AM   #52
SoCoNoHa
2.7L
 
Fav Mod: Anything custom
Join Date: Feb 2018
Location: Southern NH
Trader Rating: (1)
Posts: 439
Default So Close...

First thing I noticed when I lifted the hood yesterday morning:


******* rodents!

Anyway, the radiator hose fits like a charm, hopefully it works better for me than for GOTJ!



After I had confirmed fitment of the hose, I focused on the exhaust. I had to (well maybe not) trim some cast in heat shield mounts to make wrapping the manifold easier. See those ugly chunks of dead weight slowing me down?



No you don't.



Coincidentally I ended up with the perfect place to tap for my EGT probe.



After a quick trip to the auto parts store to buy those metal zip ties I forgot to get yesterday, I heat-wrapped my exhaust manifold. First time using the stuff, I think I did ok, and I had plenty left over to do the up pipe.





I also 'shielded' my T-stat housing, let's see if she can take the heat!



Protect ya wires



That's about it for now, I actually pretty much finished up in the engine bay. It was dark out though, and my phone was dead so no pics of that just yet.

I still have to re-install the radiator, run the vac lines, and go over all my bolts again just to be sure everything's tight. Unfortunately, before I do any of that I really should fix the timing; Twice now I've managed to get the driver side cam out of time by a tooth!

Should be firing it up today!!
__________________
97 LGT / 92 SVX / 95 GM∆
SoCoNoHa is offline   Reply With Quote
Old 04-28-2018, 07:11 AM   #53
Flat4awd
3.3L
 
Fav Mod: Owl's Auto JDM
Join Date: Aug 2008
Location: Maine
Trader Rating: (8)
Posts: 685
Default

Looking good.
Flat4awd is offline   Reply With Quote
Old 04-28-2018, 07:28 AM   #54
George.of.the.Jungle
Baby❤Daddy
 
George.of.the.Jungle's Avatar
 
Fav Mod: BOOOOOOST!!
Join Date: Aug 2002
Location: Charleston, SC
Trader Rating: (75)
Posts: 27,851
Default

with yours being a stock header/up, your turbo is in the stock location. mine is all rotated and whatnot from using the subachad up/down, which added a nice little level of annoyance.



your setup looks a lot cleaner than mine. nice work sir.
__________________
friends dont let friends put stupid GD scoops on their first gen car.
George.of.the.Jungle is offline   Reply With Quote
Old 04-28-2018, 03:23 PM   #55
SoCoNoHa
2.7L
 
Fav Mod: Anything custom
Join Date: Feb 2018
Location: Southern NH
Trader Rating: (1)
Posts: 439
Default

Thank you gentlemen, I appreciate the kind words.
Here is the completed setup:





I'd just like to point out that the turbo oil feed line sits comfortably where the MAF harness used to be...



The camshafts or timing belt fought me to the bitter end, maybe they were cooperating against me, I'm not sure. I had the tensioner in and out eight times or so, to the point it's probly at the end of its life already. It seemed as though the timing mark on the drivers side sprocket would always end up on one side or the other of the mark on the rear timing cover. I made very sure I only moved one tooth at a time and could not get it centered. In either position the engine ran like crap. I got somewhat frustrated because this was the last thing to do before firing it up. Hell, it already had fluids!
I finally got the engine to run 97% normally by putting all the sprocket marks at 12 o'clock regardless of the marks in the rear covers. Still I think it's out of time, but I'm wicked close dood. I've read about others hearing alarming noises from 22t heads until they seemed to 'settle'. So maybe it's loud ass lifters or something? Maybe it's a worn out tensioner? Could the 22t timing be different? What about the cam trigger, I didn't swap it?
Well I drove it a little and it actually drove ok...ish. I can hear spooling around 2300, which is pleasantly surprising, and it builds boost alright, but I kept my foot out of it for the most part. The rpms like to plunge after letting of the throttle, more throttle, worse it stutters. Probly due to my BOV not recirculating just yet.
It was crazy lean at first. I was seeing 18- 19:1 at idle, and cruising light throttle was from 15 to 17:1! Not cool, man.
I unplugged the vac lines for the FPR and that helped, now it's idling like 12s and cruise/throttle is 13/14:1. Sometimes it goes down to low 11s for a little bit, it's a little sporadic. Same injectors and everything else I was using before and they worked great.
Also I cracked the bottom of my radiator pushing it down into it's mounts because f that thing am i right? So now I gotta find one of those too. While we're in the area, here's some pics of my solution to having an n/a water pump.





Stayed touch-able even with the engine at operating temp and the exhaust wrap smoking like crazy, they never mentioned that in the directions.

I think I'll keep trying the timing, after a bit more research.
Cheers.
__________________
97 LGT / 92 SVX / 95 GM∆
SoCoNoHa is offline   Reply With Quote
Old 04-28-2018, 03:47 PM   #56
Flat4awd
3.3L
 
Fav Mod: Owl's Auto JDM
Join Date: Aug 2008
Location: Maine
Trader Rating: (8)
Posts: 685
Default

The lifters on those ej22t heads were noisy for me at first, then they smoothed out as I drove it. I also remember the headers weren't sealing 100% on the gaskets, so I gently re-torqued them.
Flat4awd is offline   Reply With Quote
Old 04-28-2018, 04:10 PM   #57
SoCoNoHa
2.7L
 
Fav Mod: Anything custom
Join Date: Feb 2018
Location: Southern NH
Trader Rating: (1)
Posts: 439
Default

Quote:
Originally Posted by Flat4awd View Post
I gently re-torqued them.
I think we have two different definitions of 'gently'...
__________________
97 LGT / 92 SVX / 95 GM∆
SoCoNoHa is offline   Reply With Quote
Old 04-29-2018, 05:46 AM   #58
SoCoNoHa
2.7L
 
Fav Mod: Anything custom
Join Date: Feb 2018
Location: Southern NH
Trader Rating: (1)
Posts: 439
Default

Well, I'm impressed by that cam gear bolt. 3/8ths drive just couldn't handle it, a first in my experience. And I've gotten some stuck bolts out.



Look at him back there, just laughing at me! Maybe I'll work on the SVX for a bit...
__________________
97 LGT / 92 SVX / 95 GM∆
SoCoNoHa is offline   Reply With Quote
Old 04-29-2018, 06:39 AM   #59
George.of.the.Jungle
Baby❤Daddy
 
George.of.the.Jungle's Avatar
 
Fav Mod: BOOOOOOST!!
Join Date: Aug 2002
Location: Charleston, SC
Trader Rating: (75)
Posts: 27,851
Default

for the wonmky idle and dipping, i semi solved this by drilling a small hole in the butterfly inside the TB. i don't remember what size, but it helped when the butterfly slammed shut when coming to a stop. still not perfect, but helpful. i also think my IACV is old and gunked/worn. i too do not have my BOV as a recirc. i'm not in boost when i'm coasting into a stop so i don't think it's the issue. i honestly think it's my combo of LW flywheel and LW crank pulley.

/left field tangent.
__________________
friends dont let friends put stupid GD scoops on their first gen car.
George.of.the.Jungle is offline   Reply With Quote
Old 04-29-2018, 07:35 AM   #60
Flat4awd
3.3L
 
Fav Mod: Owl's Auto JDM
Join Date: Aug 2008
Location: Maine
Trader Rating: (8)
Posts: 685
Default

Quote:
Originally Posted by George.of.the.Jungle View Post
my combo of LW flywheel and LW crank pulley.
How do you like this setup, and have you ever had this combo on n/a? I'm doing a lighter weight fw and kartboy pulley on my n/a ej1.8.
Flat4awd is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 12:12 AM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
Copyright © 2019 VerticalScope Inc.
Designed & Powered by Domain Architect