Hawk296's Old Green L - Page 9 - Subaru Impreza GC8 & RS Forum & Community: RS25.com
 
Private Support i-Trader Ratings Become a Vendor Rules for VendorsModsUsers Contact
Subaru Impreza GC8 & RS Forum & Community: RS25.com
gc8 RSS GC8 Facebook Subaru GC8 Twitter Subaru YouTube Channel Subaru Sticker
 
Login below or Register Now
Register Mark Forums Read FAQ Advertise
Go Back   Subaru Impreza GC8 & RS Forum & Community: RS25.com > >
Hawk296's Old Green L
Reply
 
Thread Tools Display Modes
Old 06-16-2019, 02:23 AM   #81
Spec R
3.3L
 
Fav Mod: CA BAR sticker
Join Date: Jan 2010
Location: Monrovia, CA
Trader Rating: (5)
Posts: 958
Default

nice build. i just went through all of it.
Spec R is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 07-13-2019, 07:39 PM   #82
Hawk296
2.2L
 
Car: 1995 L
Join Date: Jan 2004
Location: Waterford, MI
Trader Rating: (0)
Posts: 100
Default



Itís been 15 days since I have driven the car. A few weekends ago I put it on stands to fix a small but persistent Power steering leak, do an oil change and while in there, install the oil cooler I bought two years ago.

The problem is, the cooler I purchased is just way too large to fit practically when mounts and lines are attached. Sheet metal and bumper need to be cut to make it work, and it really is overkill. So I have ordered a new core about half the size and have been waiting for it to arrive ever since. Apparently when some vendors say ďin stock, ships in 2-3 business daysĒ what they really mean is they will contact their supplier in the UK sometime in the next week to have one shipped and not tell the customer. At least I donít need the car and havenít had a lot of time to work on it anyway.

I did have time to work on the steering though. The leak was on top of the crossmember between the hardlines on the rack and the hoses going up to the pump. I got a brand new set of lines for an EJ25D to replace the used EBay ones I have been using ever since the swap. I also installed a new 04í STI steering rack. I used the L&E Fabrications GD-GC steering coupler as it wasnít much more expensive than if I bought a GD coupler and made one myself, and it saved me all the labor. The L&E coupler works, but it was pretty nasty. The splines were all messy so i really had to clean them out and the threads for the bolt had to be re-tapped.






Other than being really annoying, everything fit ok and so far no leaks. As soon as the new oil cooler comes in Iíll get to work on that.

Last edited by Hawk296; 07-13-2019 at 07:42 PM..
Hawk296 is offline   Reply With Quote
Old 07-31-2019, 07:48 PM   #83
Hawk296
2.2L
 
Car: 1995 L
Join Date: Jan 2004
Location: Waterford, MI
Trader Rating: (0)
Posts: 100
Default

So the 25 row Mocal was way too big. Not only did it have hard interference with the bumper beam in just about every location but it also was a bit overkill. Note the mangled A/C condenser and damage from the original owner as well as overspray from the ďfixĒ Somehow that thing is still working problem free after all of these years!




So I got a little gun shy and ordered a MUCH smaller cooler, hopefully not too small. This one is a Setrab 1 series 16 row. It fits much nicer. If I find I need something larger I can move up to the wider version and still be okay.




Yes I still have the factory water to oil heater/cooler hooked up. I couldnít find any real data on how it affects oil temps. I figure it canít hurt to have it heating the oil up in the cold. And hopefully it doesnít warm it up too much post air-oil cooler, but thatís what Iím looking to find out. In theory, the oil should be noticeably warmer than the coolant anyway, right? I also didnít want to pull the timing belt to swap the water pumps out at this time.

Unfortunately I lost the new oil temp sensor I was going to install so I am waiting to fill and leak check until the new one goes in, hopefully tomorrow. With some luck Iíll get it wrapped up this weekend.

Last edited by Hawk296; 07-31-2019 at 08:00 PM..
Hawk296 is offline   Reply With Quote
Old 08-16-2019, 08:35 AM   #84
Hawk296
2.2L
 
Car: 1995 L
Join Date: Jan 2004
Location: Waterford, MI
Trader Rating: (0)
Posts: 100
Default

While waiting I installed a new passenger seat.




I received the new temp sensor a week and a half ago and installed it. Filled the fluids and leak checked it all. Everything is functioning well!

Did a crude toe alignment with some string, plumb bob and a measuring tape then torqued everything down. I washed the grime off and gave it a quick coat of wax.


The first test drive was 45 minutes each way to Oakos Automotive this past Sat. for a meet.


Only issue seems to be some air left in the power steering circuit. I also still need to get a proper alignment as the steering wheel is slightly off center.

Last edited by Hawk296; 08-17-2019 at 06:32 PM..
Hawk296 is offline   Reply With Quote
Old 08-16-2019, 10:07 AM   #85
SoCoNoHa
2.7L
 
Fav Mod: Anything custom
Join Date: Feb 2018
Location: Southern NH
Trader Rating: (1)
Posts: 434
Default

Daaaaaamn, looking real good!

Any update on oil temps? I'm wondering if I should scoop one.
__________________
97 LGT / 92 SVX / 95 GM∆
SoCoNoHa is offline   Reply With Quote
Old 08-17-2019, 06:19 PM   #86
Hawk296
2.2L
 
Car: 1995 L
Join Date: Jan 2004
Location: Waterford, MI
Trader Rating: (0)
Posts: 100
Default

Ive been driving it a bit more and the oil temps seem to be.... low. Sitting stuck in traffic in 80 degree F weather, I was seeing about 90C (about 195F) on the gauge. As soon as I get moving the temps drop to 65-70C (150F-160F). And I do have a 180F thermostat in the sandwich plate. Iím sure they will be higher on the track, but itís quite a bit too cool right now.

My baja with just the factory oil cooler/warmer sits right around 90C in the summer.
Hawk296 is offline   Reply With Quote
Old 08-24-2019, 03:47 PM   #87
Hawk296
2.2L
 
Car: 1995 L
Join Date: Jan 2004
Location: Waterford, MI
Trader Rating: (0)
Posts: 100
Default Power Steering Cooler

Using the Outback EJ25D power steering lines and the EJ20K pump, the return line doesnít match up to the reservoir. I had been using a small piece of line looped up over the air inlet, but after installing the new lines with the new rack, I just couldnít get it right. There was a kink in the return line reducing flow.


I never had a power steering cooler and didnít get one of the JDM ones with my swap stuff. I figure by adding one, which I should do anyway, I can solve the return hose routing solution a bit more elegantly.

Sometimes I spend top dollar on parts, sometimes I go cheap. This was done super cheap in the form of a $25, 9Ē Hayden P/S cooler kit off Amazon.

The cooler mounts in front of existing radiator or condenser with plastic zip tie like things that you fish through the fins and secure on the backside with a little locking plate. A piece of adhesive foam attaches between the P/S cooler and, in my case, A/C condenser to prevent damage.





Leak checked and so far so good except for a little bit of air in the system still. I almost feel bad. It looks so cheap right above the oil cooler which looks so nice. It should work just fine though.

Last edited by Hawk296; 08-24-2019 at 03:49 PM..
Hawk296 is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 12:39 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
Copyright © 2019 VerticalScope Inc.
Designed & Powered by Domain Architect