2001 Impreza L | WRX swapped | Rust repairs and weight reduction! - Page 88 - Subaru Impreza GC8 & RS Forum & Community: RS25.com
 
Private Support i-Trader Ratings Become a Vendor Rules for VendorsModsUsers Contact
Subaru Impreza GC8 & RS Forum & Community: RS25.com
gc8 RSS GC8 Facebook Subaru GC8 Twitter Subaru YouTube Channel Subaru Sticker
 
Login below or Register Now
Register Mark Forums Read FAQ Advertise
Go Back   Subaru Impreza GC8 & RS Forum & Community: RS25.com > >
2001 Impreza L | WRX swapped | Rust repairs and weight reduction!
Reply
 
Thread Tools Display Modes
Old 12-18-2018, 08:54 AM   #871
RavensFan77
Premium Member
 
Car: 2001 Subaru Impreza L coupe
Fav Mod: Ej205
Join Date: May 2012
Location: PA
Trader Rating: (1)
Posts: 738
Default

Quote:
Originally Posted by TerryJr View Post
i tried MAF for like an hour then went straight to SD and never looked back. Youll like it.

Getting started was the hardest part. The VE table is massive and the default values were all 100 for the whole table. Definitely starting to like it now that Iíve been messing around with it.

The car was speed density from the factory with the ej222, so itís only right that it returns to SD now.


óóóóó



Didnít get much done because as usual it rained all weekend. There was a few hours when it stopped and I got the car out for a 30 minute round trip drive, and made some tweaks to the tune. Looking pretty good in closed loop. Just need to put the wideband somewhere to start the open loop stuff.

I swapped out the 1/8Ē fittings on my EBCS to 1/4Ē. Supposed to help with boost control and the fittings on the ewg are 1/4Ē anyway.



Put a 5 psi spring in the ewg. Just wanna run small springs at first with 0 DC to slowly work my way up to higher loads. Once I work up to a 10-15 psi spring Iíll start adding WGDC.

The last turbo had a 17 psi spring and I liked tuning it that way. The spring does a lot of the work, and seemed easy to control.



And got the dump tube tacked together. Needed a bit of an angle because a straight piece was too close to the axle boot for my liking. Now with the slight bend itís got a lot more room, and with the v-bands I can roll it a little either way to get it right where I want.

Gonna weld it this weekend and hopefully weld a bung on the downpipe for the wideband too.



RavensFan77 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 12-18-2018, 09:20 AM   #872
TerryJr
Experimenter
 
TerryJr's Avatar
 
Fav Mod: AAA Premier
Join Date: Jun 2009
Location: Pittsburgh
Trader Rating: (0)
Posts: 3,832
Default

tuning. My VE tables about 55% at idle 60-70 through cruise and towards 100 at wot if that helps any. Peak VE usually same cells as peak boost.
__________________
Why should we be paying to keep guy's like Chris Watts and Michael Glance alive?
TerryJr is offline   Reply With Quote
Old 12-18-2018, 04:53 PM   #873
RavensFan77
Premium Member
 
Car: 2001 Subaru Impreza L coupe
Fav Mod: Ej205
Join Date: May 2012
Location: PA
Trader Rating: (1)
Posts: 738
Default

Quote:
Originally Posted by TerryJr View Post
tuning. My VE tables about 55% at idle 60-70 through cruise and towards 100 at wot if that helps any. Peak VE usually same cells as peak boost.

That seems right on from what Iíve read. 50-60 in idle/throttle lift, 60-80 in cruise, and up to 100 (or more) at WOT. My values fall within those, maybe a bit on a higher side. Need more driving and logging though.

The higher boost stuff makes me a bit nervous, but I plan to overestimate and be on the safer side at first. Slowly work my way up to target boost and take lots of logs.
RavensFan77 is offline   Reply With Quote
Old 01-04-2019, 06:25 AM   #874
RavensFan77
Premium Member
 
Car: 2001 Subaru Impreza L coupe
Fav Mod: Ej205
Join Date: May 2012
Location: PA
Trader Rating: (1)
Posts: 738
Default

Dump tube is welded and I added a bung for the wideband to my downpipe. Did some testing at 5 psi, then changed EWG springs for 10 psi and did more testing.

Short video. Donít pay much attention to the AFRís.....still need to dial them in. Terry you were right, this turbo is quite the noise maker. Loud even at low boost.

‘01 Impreza Borg Warner s257sxe 10psi test - YouTube

More detailed stuff:

Been going on longer and longer drives. Ran around with it a bunch last weekend and itís driving pretty good. Tip-in is a little weird at certain times, same with hot restarts, but thatís almost expected. Itís not that bad, and doesnít happen all the time. More driving and I should be able to get it all smoothed out. Overall Iím still surprised at drivability on speed density so far. Still lots of work to do, but a good start.

When I put in the EWG springs for 10 psi, I zeroíd the WGDC table. Also took out like 1-1.5* of timing and added some fuel up top to be safer at first while I start going up in MAP and RPM. Looking good so far. AFRís are a little jumpy, but pretty damn close to target. Only doing like 50% throttle to 5,000-5,500 RPM right now.

The 10 psi springs make me hit 11-12 depending on incline and stuff. Just gonna slowly work my way up to 20+. At some point Iíll start breaking stuff, so weíll see how far I get.
RavensFan77 is offline   Reply With Quote
Old 01-05-2019, 09:05 PM   #875
bue car
#32
 
bue car's Avatar
 
Fav Mod: Which car?
Join Date: Jun 2008
Location: Torrance, CA
Trader Rating: (173)
Posts: 11,769
Default

Weee!

I gave it a thumbs up
__________________
Save RS25! Say no to XenForo
bue car is online now   Reply With Quote
Old 01-08-2019, 08:01 AM   #876
RavensFan77
Premium Member
 
Car: 2001 Subaru Impreza L coupe
Fav Mod: Ej205
Join Date: May 2012
Location: PA
Trader Rating: (1)
Posts: 738
Default

Not much to update on. Fixed some drivability stuff last weekend. Mostly tip-in/tip-out/overrun stuff in the tune. Made a nice difference when lifting throttle, and low speed parking lot stuff. Thatís about it for progress.

Separate issue....I canít tell if my bov is operating correctly or not. I get a bit of flutter/surge noise shifting at low boost (5psi or so). If I loosen the bovís cap to where I get no flutter, the piston/valve wonít stay closed at idle. If I continue to tighten it the flutter/surge noise comes back at low boost and gets worse the tighter I go......but still no flutter at 10psi and up.

So is some flutter at low boost acceptable? It seems to be a HUGE debate whether its bad for the terbo or not. About to just weld a port onto my intake and use the factory BPV cause this is annoying me.

What say ye Rs25?
RavensFan77 is offline   Reply With Quote
Old 01-08-2019, 08:04 AM   #877
Ted
2.5L RS-T
 
Join Date: Sep 2011
Location: The Shire
Trader Rating: (3)
Posts: 5,159
Default

Quote:
Originally Posted by RavensFan77 View Post
Not much to update on. Fixed some drivability stuff last weekend. Mostly tip-in/tip-out/overrun stuff in the tune. Made a nice difference when lifting throttle, and low speed parking lot stuff. Thatís about it for progress.

Separate issue....I canít tell if my bov is operating correctly or not. I get a bit of flutter/surge noise shifting at low boost (5psi or so). If I loosen the bovís cap to where I get no flutter, the piston/valve wonít stay closed at idle. If I continue to tighten it the flutter/surge noise comes back at low boost and gets worse the tighter I go......but still no flutter at 10psi and up.

So is some flutter at low boost acceptable? It seems to be a HUGE debate whether its bad for the terbo or not. About to just weld a port onto my intake and use the factory BPV cause this is annoying me.

What say ye Rs25?
Sounds like the blow off valve can't evacuate the air efficiently enough for your turbo.

Sent from my SM-N920V using Tapatalk
__________________
A three syllable word for thoughts too big for small minds
Ted is offline   Reply With Quote
Old 01-08-2019, 08:52 AM   #878
RavensFan77
Premium Member
 
Car: 2001 Subaru Impreza L coupe
Fav Mod: Ej205
Join Date: May 2012
Location: PA
Trader Rating: (1)
Posts: 738
Default

Quote:
Originally Posted by Ted View Post
Sounds like the blow off valve can't evacuate the air efficiently enough for your turbo.

Sent from my SM-N920V using Tapatalk

Just weird that thereís no flutter if I loosen the cap a bunch, but then the valve/piston wonít stay closed at idle. Which isnít really an issue with speed density, but Iíd still rather have it be closed like itís supposed to.

just trying to find that balance of keeping the piston/valve closed at idle and not having flutter/surge. Seems like a fine line with this one
RavensFan77 is offline   Reply With Quote
Old 01-10-2019, 09:16 AM   #879
Rsfanatic
1.8L
 
Car: 2001 RS 2.5 sedan- SOLD
Join Date: Sep 2014
Location: San Diego
Trader Rating: (0)
Posts: 42
Default

Love the progress man! Bummer about the accident but glad you kept the car
Rsfanatic is offline   Reply With Quote
Old 01-10-2019, 04:45 PM   #880
RavensFan77
Premium Member
 
Car: 2001 Subaru Impreza L coupe
Fav Mod: Ej205
Join Date: May 2012
Location: PA
Trader Rating: (1)
Posts: 738
Default

Quote:
Originally Posted by Rsfanatic View Post
Love the progress man! Bummer about the accident but glad you kept the car

Thanks! Iím glad the people on this forum convinced me to keep it and fix it myself. Learned so much along the way. Kind of a blessing in disguise looking back.

Just realized that was 3 years ago. 2 since itís been fixed. Feels like just the other weekend I was drilling spot welds, getting bit by black widows, and test fitting the front end 1000 times.
RavensFan77 is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 09:50 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
Copyright © 2019 VerticalScope Inc.
Designed & Powered by Domain Architect